3

I am trying to make a RPi 1 work nicely with an old LCD PAL TV (Sony KLV-20SR3). The video signal goes over composite (over SCART) because HDMI is not available. I am using LibreELEC.

By default the picture overflows the screen, but playing with overscan_scale=1 and overscan_{left,right,top,bottom} I can make the display area right. The results are, however, ugly.

I suppose the problem is due to the fact that the RPi thinks that the resolution of the screen is 720x576 (probably due to sdtv_mode=2 #PAL) while the resolution of the LCD of this TV is exactly 640x480. I suppose that scaling the framebuffer is what makes everything blurry.

I tried setting framebuffer_width=640 and framebuffer_height=480 but the screen resolution is still the same. (If I read http://elinux.org/RPiconfig correctly, these settings work only for the console.)

How can I set the video resolution when using the composite output?

3

I read at https://discourse.osmc.tv/t/composite-sd-resolution-of-osmc-skin-video-output/5445/3) that

Composite is fixed resolution (720x480@60i for NTSC, 720x576@50i for PAL).

So you cannot change it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.