0

I recently purchased a Raspberry Pi 3 Model B which I am beginning to think is damaged or defective.

I originally installed Ubuntu Mate to a 4gb Sandisk microsd card and ran the Pi that way for about 1 week. The pi constantly encountered a kernel panic and shut down, so I decided to switch to raspbian. But, no matter what I try, Rasbian Jessie Lite nor NOOBS will boot.

I have tried using win32diskimager, and Etcher to flash the Jessie lite images and have tried the following images on my SD card:

  1. 2016-09-23
  2. 2016-02-09
  3. 2016-02-26
  4. 2016-05-10

In each case, I get one green LED at boot, the red led, and one large rainbow square image (not the under-voltage square).

I have tried using GUIFormatter (linked somewhere in a forum) and the SDFormatter linked by the foundation to completely reformat the disk (including resizing the partitions and doing an overwrite format) and have tried Noobs 1.8,1.9, and 2.0 (the lite versions where possible as my SD card is small). In each case I get one green flash and the solid red light.

I am currently using a 5v 2.5a power supply purchased in a starter kit and have no reason to assume it is causing a voltage issue. I have swapped out the usb cable and the power supply (albeit for a lower amperage unit temporarily). I currently don't have access to a second microsd card, but I don't suspect this is the problem because each time I install Ubuntu Mate, the card works! I am not sure what other steps I can try.... which leads me to my post.

I am trying to determine if this Pi-3b is actually damaged before buying a new card or attempting a return. I purchased it a few months ago and just now had time to begin using it.

  • Update: I was able to scrounge up a 2Gb microsd card tonight, so I flashed the latest Jesse Lite image onto it (too smart for NOOBS), and I still get the solid red light, 1 blink on the green led, and the color wheel on my screen (using HDMI) with or without a keyboard and ethernet connected. – Andrew Best Nov 27 '16 at 6:54
  • 1
    AFAIK You cannot run Raspbian on a 4GB card (the download image is >4GB). It barely fits on 8GB. You will surely have got some kind of error message. – Milliways Nov 27 '16 at 8:34
  • Thanks for the reply. This is Jesse Lite (the 1.4 gig no gui install) so it should fit just fine. Same for NOOBS, if I get NOOBS lite its a very small download. – Andrew Best Nov 27 '16 at 18:39
  • Verify Checksums – jet Nov 27 '16 at 22:02
  • A coloured splash screen is displayed after GPU firmware (start.elf) is loaded. This should be replaced by linux console a second later. However if the coloured screen remains, it suggests the kernel.img file is failing to boot. raspberrypi.stackexchange.com/a/19356/8697 – Milliways Nov 27 '16 at 22:20
0

The board was defective. I replaced it and successfully booted on the 4 GB Card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.