I'm trying to share some files with my macbook (running OS X El Capitan v10.11.4) so that I can edit them without uploading them after each edit.

I've tried this guide and I can connect to the pi and see the shares. When I try and access them though, I get this:

The operation can't be completed because the original item for "home" can't be found.

Why would I get that message?

[Edit] @ Milliways - this is step by step what I did:

  1. Downloaded NOOBS to install Raspbian from the raspberry pi website.
  2. Set a static IP address on the PI.
  3. Enabled SSH access.
  4. Ran the sequence of commands* below.
  5. Connected from my Macbook to the Raspberry PI in OSX Finder and selected whereupon I could see the default share that netatalk suggests.
  6. Clicked on the home share and when prompted, entered the pi | raspberry default pi credentials.

*Sequence of commands:

sudo apt-get update
sudo apt-get install netatalk
sudo /etc/init.d/netatalk stop
sudo nano /etc/netatalk/AppleVolumes.default
sudo /etc/init.d/netatalk start

...and that's when I got the error message mentioned above.

[Edit2] - This is what my netatalk file changes look like:

# The line below sets some DEFAULT, starting with Netatalk 2.1.
:DEFAULT: allow:pi options:upriv,usedots,noadouble,rw

# By default all users have access to their home directories.
~/                      "home"
/                       "pi-root"
  • 1
    Which OS are you running on the Pi? DON'T post links to tutorials, tell us what YOU ACTUALLY did.
    – Milliways
    Commented Nov 27, 2016 at 22:35
  • @Milliways - Does the edit above help?
    – Jon Cage
    Commented Nov 28, 2016 at 9:20
  • You haven't specified OS, I assume Raspbian. Steps 1. 2. are irrelevant Most of what you have done in 4. is also unnecessary. You may have run sudo nano /etc/netatalk/AppleVolumes.default, but this doesn't explain what if any (unnecessary) changes you may have made. You should include the contents of this file in your question.
    – Milliways
    Commented Nov 28, 2016 at 9:50
  • I have found trying to open shares in Finder is often less than satisfactory. I use open afp://raspberrypi.local, although you can use IP address.
    – Milliways
    Commented Nov 28, 2016 at 10:01
  • I did mention (in the edit) it's Raspbian, installed via NOOBs. I'm sorry if some of this seems vague but I'm new to the Raspberry Pi and trying my best to explain what I've tried etc.
    – Jon Cage
    Commented Nov 28, 2016 at 10:17

3 Answers 3


As Apple abandoned AFP in favor of SMB3 you should try using samba instead.

  • Any pointers on how Samba should be used?
    – brasofilo
    Commented Sep 26, 2019 at 18:14

You have followed an old SysV guide, and probably messed something up. See https://raspberrypi.stackexchange.com/a/39665/8697 - all you should NEED to do is install netatalk. You could then customise /etc/netatalk/AppleVolumes.default, but this is NOT necessary to get home.

I use netatalk all the time, and often cannot connect, after my Mac has been sleeping, so I restart the service on the Pi with sudo systemctl restart netatalk.


try NFS protocol, which is native for Unix* OS-es and is fast

  1. Share a directory in RPi (/etc/exports)
  2. Mount it from Mac (sudo mount -o rsize=32768,wsize=32768,intr,noatime -t nfs RPi_IP_addr:/sharename /folder_to_mount_it )

or Using SSHFS which is slower, but secure (encrypted)

  1. Enable ssh on RPi
  2. Install sshfs client on Mac (http://osxfuse.github.io/)
  3. Mount SSH resource on Mac (sshfs user@RPi_IP_addr:/dir /mount_folder -ocache=no -onolocalcaches -ovolname=ssh)

Samba also should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.