I am very new to raspberry Pi, I have performed initial connections like connecting microusb and Ethernet cable to my computer and raspberry pi device , I use 16GB SD card, but when i check the devices mounted on my computer i could not see if my SD card is mounted , unfortunately i could not see any thing mounted in my computer

I am using Ubuntu 16.04 LTS , kindly suggest me any possible reason why i am facing this issue

dev@dev-Compaq-15-Notebook-PC:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            1,7G     0  1,7G   0% /dev
tmpfs           340M   10M  330M   3% /run
/dev/sda2       455G   35G  398G   8% /
tmpfs           1,7G  2,2M  1,7G   1% /dev/shm
tmpfs           5,0M  4,0K  5,0M   1% /run/lock
tmpfs           1,7G     0  1,7G   0% /sys/fs/cgroup
/dev/sda1       511M  3,6M  508M   1% /boot/efi
cgmfs           100K     0  100K   0% /run/cgmanager/fs
tmpfs           340M   88K  340M   1% /run/user/1000

The model that i have is Raspberry pi 3

  • So, you have a Raspberry Pi 3. You hooked it up to your network (Ethernet), power (microUSB) and inserted the SD card (into the Pi). Then you tried to find said SD card (which is in your Pi) on your notebook? Or did you insert the SD card directly into your notebook? Nov 28, 2016 at 9:08
  • @Fantilein1990, I tried to find SD card which is in my Pi on my notebook, i did not inset SD directly into my notebook
    – DevanDevak
    Nov 28, 2016 at 9:20
  • That doesn't work the way you tried it. A Raspberry Pi is an computer of its own, not an USB device. You would have to make it accessible as a network device, then it will work. What is on your SD card? Nov 28, 2016 at 9:30
  • Nothing is on my SD card , I brought new SD card 16GB, kindly let me know how i can make Raspberry as network device
    – DevanDevak
    Nov 28, 2016 at 9:38

1 Answer 1


As I pointed out in the comments, inserting an empty SD card into a Raspberry Pi and trying to access that SD card via USB or LAN from a different computer is not going to work. The Raspberry Pi is a computer of its own and you wouldn't be able to access a hard drive in a regular computer with no operating system either. What you'll have to do is set up the SD card befort inserting it into a Raspberry Pi.

There are several ways of setting up a Raspberry Pi SD card, but all of them start with inserting the SD card into a computer using a SD card reader (many notebooks have them built in). That way, you'll be able to access the card like a regular flash drive.

Once you have access to the SD card, the easiest way to start is by downloading NOOBS and putting it on your SD card (you can follow this tutorial by the official Raspberry Pi Foundation).

Once you have done this, you can insert the SD card into your Raspberry Pi and start it for the first time (if you use NOOBS, you need to attatch a display).

To access it remotely (e.g. from a different computer in the same network), you can use SSH (following this tutorial, again provided by the official Raspberry Pi Foundation).

  • How to start Raspberry for first time, do i have to boot my computer from SD card ?, when i start rebooting my computer i could not see any SD card , what should i do in such case
    – DevanDevak
    Nov 29, 2016 at 6:45
  • Boot your computer from SD card? No, your computer should continue to run UBUNTU and you just attach it like a USB drive/external hard drive using a card reader. Then you download NOOBS onto your computer, unpack it and copy it to the SD card. Then you dis-attach the SD card from your computer and insert it into the Raspberry Pi. Then you connect the Raspberry Pi with a keyboard, a mouse, a display and finally with a USB power cable (the microUSB plug is for that power). Then the Raspberry Pi should start up. Nov 29, 2016 at 8:22
  • I have inserted SD card into Raspberry PI and connected it to my laptop, with USB powercable, but its not starting up
    – DevanDevak
    Nov 29, 2016 at 8:40
  • I have laptop with ubuntu 16.04 LTS on it, and i want to boot the raspberry
    – DevanDevak
    Nov 29, 2016 at 9:11
  • I am getting connection refused, when i use putty to connect to raspberry pi
    – DevanDevak
    Nov 29, 2016 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.