1

I'm trying to configure my PI to use as a fileserver, but after reading every tutorial on this from google, I still can not figure out what is wring with my settings.

/media/pi/USBHDD permissions:

pi@raspberrypi:~ $ ls -l /media/pi/USBHDD
total 0
drwxrwxrwx 1 root root 0 Nov 28 18:45 MediaShare
drwxrwxrwx 1 root root 0 May 11  2016 System Volume Information

Samba config:

[MediaShare]
        path = /media/pi/USBHDD/MediaShare
        writeable = yes
        only guest = yes
        create mask = 0777
        directory mask = 0777
        browseable = yes
        public = yes

What I get when I try to access it:

I'm a beginner unix user. I'm going bald over this, please help!

  • I've seen this tutorial link suggested on many questions, so I've done it from scrap, still no results. – Puppetier Nov 28 '16 at 23:27
  • This started to happen to me on Windows 10 recently. It worked fine for years. It must some new "no password" default policy in the registry. I have not worked it out yet. – Piotr Kula Nov 29 '16 at 8:11
  • It's good to know someone else have bumbed into this. I'll try to fiddle with it, maybe find something. – Puppetier Nov 29 '16 at 8:54
  • I think the username needs to be something like <something>/Guest and blank password. I saw this pop up on another Win10 machine yesterday and it worked. I am looking for more details on this now. – Piotr Kula Nov 30 '16 at 8:18
  • So I've tried for some time now, and still no results, managed to take ownership of the external drive to the pi user, so now no root involved. But still, as I log in, I still get the access denied response. This means, that the user/password is correct. I have no idea what could deny my access anymore... samba accepts my login, and the drive is owned by pi. – Puppetier Nov 30 '16 at 20:39
1

Finally I managed to solve this. I messed up the config, further down below my share it contained a line "valid users = %s", so of course no user could access the share.

What finally worked for me:

[global]
security = user
usershare allow guests = yes

[MediaShare]
path = /media/USBHDD/MediaShare

Everything else is the default. This way I can log in with users added with smbpasswd.

The important part is making sure, that you declare your share before or after the home share. My main problem was writing inside the home share, so some settings stuck with me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.