1

I am using a Raspi 3B running Jessie /proc/ver shows it as 4.1.17 if that is useful?

I am trying to build a kiosk system for a project and have run into an issue that I cannot seem to fix. I have a script that contains the following code

#!/bin/bash

while true;
do
        rm -rf /home/pi/.config/<program>/*
        cp -R /home/pi/.config/<progbackup>/* /home/pi/.config/<program>

        openbox --config-file ~/.config/openbox/lxde-pi-rc.xml --startup /opt/2X/Client/bin/ClientApp

done

this is run at bootup using xinit scriptname.sh

This appears to work as expected and the client app is the only item launched, however if the user right clicks on the "desktop" they are given a menu that among other things offers them a terminal window.

I have tried to modify the autostart file in /etc/xdg/lxsession/LXDE-pi/ from another article that suggested this would solve the issue but after a reboot of the Pi the menu still exists.

This is my first steps into setting up a custom kiosk using a window manager and am still learning a lot about how they all work together, so please don't assume I know what I am doing :)

1

OK so I managed to fix this, it seems that I was looking in all the wrong places. its not part of LXmanFX as I first assumed, its part of the OpenBox configuration.

For reference you need to modify the following file

/home/pi/.config/openbox/lxde-pi-rc.xml

search the file looking for mouse actions that match the button In question.

  <mousebind button="Right" action="Press">
    <action name="Focus"/>
    <action name="Raise"/>
    <action name="ShowMenu">
      <menu>client-menu</menu>
    </action>
  </mousebind> 

you may have a few of these entries (I had 5 in total). comment them out using the HTML comment strings

<!--      <mousebind button="Right" action="Press">
        <action name="Focus"/>
        <action name="Raise"/>
        <action name="ShowMenu">
          <menu>client-menu</menu>
        </action>
      </mousebind> -->

making sure you capture all the correct open and close tags for the section. save the file and reload openbox (or reboot your Pi) and the right click menu no longer works.

hope this helps someone out as much as it did me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.