1

I've got a Pi Zero with a fresh Rasbian OTG setup working fine, but I can't seem to share my Mac's wifi with the unit. I've turned on connection sharing on the Mac, set up static IP addresses, etc etc. I've essentially followed every guide I could find online and it shows up as connected like so:

settings

Pinging the Pi from the Mac seems to work:

ping 192.168.7.2
PING 192.168.7.2 (192.168.7.2): 56 data bytes
64 bytes from 192.168.7.2: icmp_seq=0 ttl=64 time=0.142 ms
64 bytes from 192.168.7.2: icmp_seq=1 ttl=64 time=0.169 ms
64 bytes from 192.168.7.2: icmp_seq=2 ttl=64 time=0.168 ms

But pinging google.com from the Pi times out. Where am I going wrong?

pi@raspberrypi:~ $ ping google.com
ping: unknown host google.com
  • To eliminate the obvious, did you reboot the PI? – Steve Robillard Dec 1 '16 at 17:03
  • Yeah, many times. :) – cd-rum Dec 1 '16 at 17:04
0

Seems like a decent enough answer to this is in this writeup, to wit:

On macOS, go to System Preferences > Sharing > Internet Sharing and enable sharing internet from wifi to thunderbolt ethernet. This will begin a DHCP server to assign your PI and IP address. It will also allow your PI to access the internet through your mac once you ssh into it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.