0

Let me first say I have a rpi 2 model B with the official 7" display and a old tablet lipo battery. It has Kali Rolling on it. I have tinkered with it quite a bit at this point...

I need to auto login to the user account "admin"

I have done the tutorial online to auto login Kali Linux by editing the dameon.conf file and unmasking the 2 lines (in my case I changed root to admin (admin is my user account). But it still shows the login screen. My goal is t get to the desktop without a keyboard. Thanks!!!

The daemon.conf is exactly how it was default except this section was changed, as follows:

[daemon] # Enabling automatic login       AutomaticLoginEnable = true AutomaticLogin = admin
  • Given that Kali is a security based distro removing the pssword is a bad idea. – Steve Robillard Dec 3 '16 at 1:01
  • It's only for traffic analysis – Bionic Bouncer Dec 3 '16 at 1:33
  • As @SteveRobillard suggested can't you try using the normal user. I haven't tried Kali in my case its pi for raspbian. Then provide some elevated privilege (sudo) as per your need. – Varad A G Dec 3 '16 at 1:55
  • @Varad A G that is pretty much what I am going for, I want to have to 'sudo' for the things I want to have elevated privileges. – Bionic Bouncer Dec 3 '16 at 1:57
  • @BionicBouncer can you add the /etc/gdm3/daemon.conf file in the question. I think you would have edited this file – Varad A G Dec 3 '16 at 2:19
1

Setting up of Autologin changes from GNOME and KDE

Step 1: Identify the Desktop Environment that is used.

echo $DESKTOP_SESSION

This should tell you which environment that is used at login.

For GNOME Users

1. sudo vi /etc/gdm3/daemon.conf

  [daemon]
  # Enabling automatic login
    AutomaticLoginEnable = true
    AutomaticLogin = <username>

2. Save the file
3. Reboot.

For KDE Users

1. sudo vi /etc/kde4/kdm/kdmrc
2. Add the below lines to the end-of-file. Don't forget to change the **AutoLoginUser**


[X-:0-Core]
AllowRootLogin=true
AutoLoginAgain=true
AutoLoginDelay=0
AutoLoginEnable=true
AutoLoginLocked=false
AutoLoginUser=<username>
ClientLogFile=.xsession-errors

3. Save the file and reboot.
  • I did the GNOME one and changed it but still don't auto login (I tried root and admin usernames) – Bionic Bouncer Dec 3 '16 at 2:59
  • @BionicBouncer Can you give me the OS details from uname -a command output. I can try this out today on my RPi and get back to you. – Varad A G Dec 3 '16 at 3:01
  • Output was : Linux Kali 4.1.19-v7 #1 SMP Tue Mar 15 15:10:00 CDT 2016 armv71 GNU/Linux – Bionic Bouncer Dec 3 '16 at 3:04
  • Is there a way I can run a verbose log of the startup to see what happens when it gets to the point to automatically login? – Bionic Bouncer Dec 3 '16 at 3:35
  • @BionicBouncer I am not sure if you will be able nail it down that way easily. I am downloading the Kali Linux 2.1.2 , the latest one to test it out. I had switched Raspbian yesterday :) – Varad A G Dec 3 '16 at 4:53
1

The original answer can be found at this link

Basically I was on XFCE and did not realize it. You must edit the lights.conf file to allow auto login. Instructions on that site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.