3

My Raspberry Pi 3 built-in Wi-Fi card has some serious problem. The Wi-Fi connection is lost very frequently (every 5-10 mins). I googled this problem and found some solutions to solve this:

  • Turn off the power management of wlan card.

    sudo iw dev wlan0 set power_save off 
    
  • Keep running this script using crontab

    /bin/ping -c2 -I $wlan $pingip >/dev/null 2>&1
    
    if [ $? -ge 1 ] ; then
        echo "Network connection down! Attempting reconnection."
        /sbin/ifdown $wlan  
        /bin/sleep 5
        /sbin/ifup --force $wlan 
    else
        echo "Network is Okay"
    fi
    

    I schedule the above script after every 10 min, but still losing connection. Wi-Fi works fine on smartphone and laptop.

What could be the possible reason and its solution?

  • power supply ... – Piotr Kula Dec 5 '16 at 12:30
  • @ppumkin; I don't think so. Its 5V, 2.5 amp power adapter. – haccks Dec 5 '16 at 13:04
  • Where did you get it from? Also the USB cable is also very important, where did you get the cable from? – Piotr Kula Dec 5 '16 at 13:05
  • @ppumkin; Already did that. Same problem with charger. I thing something wrong with pi-3 wlan card, though not sure. – haccks Dec 5 '16 at 13:16
3

I had the same problem (RPi's Wi-Fi had been working about 5 minutes after boot). And fixed it by switching Wi-Fi channel from 12th to 3rd on my HUAWEI router. (In North America 12,13,14 channels is low power Wikipedia WLAN channels)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.