1

enter image description here

I am a beginner and this is my second pi the first one broke but the camera just worked the other day

0

4 Answers 4

2

I struggled with the same problem for hours before the forehead-slap-worthy realization that I had the camera cable inserted upside down into the raspberry pi's slot :/ Thought I'd post that here in case it helps others :)

1

The error message on the screen you posted contains a clear instruction what to do:

Try running sudo raspi-config and ensure that the camera has been enabled.

This problem "Out of memory" is also described in the FAQ for Pi camera with clear instructions:

Run sudo raspi-config, select the “Enable Camera” option, select “Enable”, and then “Finish”. You will need to reboot to complete the process.

2
  • 4
    what could be a reason if this doesn't help ? :I
    – Boern
    Commented Jun 21, 2017 at 16:48
  • 1
    this does not work for me...
    – JustWe
    Commented Jun 6, 2018 at 2:05
0

I must have slightly knocked the camera ribbon where it connected on the board and started getting this error. After I re-seated the ribbon, it started working again.

0

Depending on the intended application (literally, as in the program initiating the camera to do a thing) it could be the GPU core running out of memory for some reason. I'm using an old RPi model B v2 streaming a 5MP module with a program called 'RPi cam web interface' being used as a front yard security camera that recently started popping a similar no memory error. The internet scuttlebutt says to raise the GPU memory split to at least 144mb to give the camera enough space to encode in the GPU core, mine was at 160, but raised it to 192 to quell the errors and get the feed back up and running. For me, the give away to check the GPU split is the "cannot create component: vc.ril.camera ... No memory" line.

Run 'sudo raspi-config' goto Performance Options, and GPU memory. Change the value to 192 (remember, the Raspberry Pi shares its memory between the GPU and CPU, meaning giving the GPU more space means your CPU has less space to rub programs in. So don't go crazy with raising it if you decide to experiment with that setting), hit tab to get to the ok/cancel 'buttons', hit space to select ok, then select back until you see the 'finish' option. Let it reboot and you should be able to initiate the camera (supposing nothing else is wrong).

You can also check 'vcgencmd get_camera' which should return 'supported=1 detected=1' if the camera is connected properly and able to initialize.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.