0

This question already has an answer here:

I just bought a raspberry pi 3 with not previous experience. I want to run my pi without keyboard and mouse.

I do have an old tv that can be used to display the output. Now this way I first got a message 'internet connection required' when I booted up.

Connected the pi with ethernet to my laptop and enabled connection sharing (which had no effect on the pi's internet connection for some reason).

So I connected the pi directly to my router. Now by some trial and error I found out the ip of my pi, in this case 192.168.2.13 when running ping 192.168.2.13 I get responses when I plug the ethernet cable in, and none when I take it out. (name is 'recovery'?)

The problem is that I can't seem to ssh into the pi, running ssh 192.168.2.13 returns 'Connection refused'. PuTTy can't connect to it either.

I can't seem to find a solid guide which works for me. Just wondering if it is possible at all to ssh to my pi when it's still in the selection screen?

(I have a pi 3 currently in the NOOBS selection screen for an OS)

Referenced guides:

marked as duplicate by goldilocks Dec 10 '16 at 21:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why the downvote? New to this stackexchange site and read the tour. Seems to be an appropriate question – Ivaro18 Dec 10 '16 at 16:56
  • I think you need to enable ssh in the first place through raspi-config. – SAMPro Dec 10 '16 at 17:03
  • This suggests that ssh is not enabled at that stage but it's from over a year ago so it could be different now. – Ghanima Dec 10 '16 at 17:26
  • Yes, "connection refused" indicates there is no SSH running. – goldilocks Dec 10 '16 at 21:47
0

There is a similar question: SSH not working with fresh install

Here is the accepted answer from the user techraf, which is a quote from the raspberry pi documentation:

As of the November 2016 release, Raspbian has the SSH server disabled by default. You will have to enable it manually.

Enter sudo raspi-config in the terminal, first select advanced options, then navigate to ssh, press Enter and select Enable or disable ssh server.

For headless setup, SSH can be enabled by placing a file named 'ssh', without any extension, onto the boot partition of the SD card.

  • 1
    If you find a question has an answer under a different one, please use the "flag" link and mark the question as a duplicate, instead of repeating the content. – techraf Dec 10 '16 at 21:13
  • Thanks for the info, but I couldn't flag a question because I have not enough reputation. – uebme Dec 11 '16 at 9:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.