-1

A few hours ago, I was able to SSH into my pi at the address 192.168.2.0 by doing ssh pi@192.168.2.0, then I got brave and tried to set up port forwarding on my router. It changed the IP ranges to things like 10.0.0.1, but then I changed it back.

Now I can do ping raspberrypi.local and it is successful, sending packets. It tells me the new IP is 192.168.1.11 but now I can't ssh into it, it says: connect to host 192.168.1.11 port 22: Connection refused.

Any ideas?

  • 3
    192.168.2.0 does not look like an IP address of your Pi. – Jakuje Dec 12 '16 at 21:12
  • Please describe your network configuration. Using 192.168.2.0 as device address is quite unusual, and it sounds like you have network configuration issues well beyound the Pi and SSH. – Dmitry Grigoryev Dec 12 '16 at 23:53
  • this is not a bad question, idk the downvotes. my network is configured using an apple airport extreme. – scott Dec 13 '16 at 6:08
  • If you describe your network configuration as "using an apple airport extreme", then you should ask Apple for support, since people who don't own this gadget have no way of knowing how it works. – Dmitry Grigoryev Dec 13 '16 at 9:41
  • wait to clarify, 192.128.2.0 is the local address of the pi i'm trying to access, not the external one, sorry for the confusion. That's a standard local address right? – scott Dec 13 '16 at 23:10
0
  1. Try ssh pi@raspberrypi.local
  2. do sudo ifconfig eth0 if using an ethernet connection to find IP.
  3. do sudo ifconfig wlan0 if using WiFi connection.
  4. The "inet" address is the IP.
  • 1
    OPs entire issue is they can't ssh into the Pi... – stevieb Dec 13 '16 at 14:38
0

Recent release of Raspbian (and possibly other distributions) disables the ssh server by default. You can re-enable by either creating a file called ssh in /boot or by enabling it in raspi-config.

  • The OP didn't say anything about reflashing, he only changed router settings. – Dmitry Grigoryev Dec 13 '16 at 9:33
  • it's enabled and i just checked it to make sure, plus i SSHed in a couple days ago, i just can't anymore – scott Dec 13 '16 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.