I have recently bought a Logitech T650 wireless USB touchpad. This touchpad works fine in the Raspbian desktop environment.

But when I run some applications, this mouse doesn't work inside the application. The regular mouses (both wired and wireless) work fine (move, click, ...), but this T650 mouse doesn't work inside some applications.

For example:

I checked /dev/input, and the Logitech USB receiver is listed there.

pi@raspberrypi:/dev/input/by-id $ ls


I tried booting into CLI (text mode) which is without X. But still the touchpad mouse doesn't work during the game.

Any suggestions?

How can I make this wireless USB touchpad work inside all applications?

Your help would be highly appreciated. Thanks for your time.

  • Any help would be highly appreciated :)
    – Omid1989
    Commented Dec 14, 2016 at 11:05
  • Any suggestions !!!!!!?
    – Omid1989
    Commented Dec 15, 2016 at 5:48
  • what specific applications don't work with the touchpad or is it just 3D frog and Urho3D; which is just a game engine not really an application?
    – linuxgnuru
    Commented Dec 17, 2016 at 12:00

2 Answers 2


I found the answer to this problem in the following topic:



  1. Create a new file /etc/modprobe.d/hid_logitech_hidpp.conf and add options hid_logitech_hidpp disable_raw_mode=1 to it.

  2. Power off the host, remove the "unifying receiver" (the little USB dongle) and turn off the T650 (set the switch on the left so that it shows red).

  3. Power on the host and go through the Linux boot process.
  4. Re-insert the receiver and turn the T650 back on.
  • Well, at least now we know which touchpad not to buy. Commented Dec 20, 2016 at 9:59

I am not sure this counts as a specific answer but as you are using a Logitech "Unifying" receiver you may like to get the Solaar utility from its Github site or an older version from the solaar package in the Raspbian (assuming that is what you are using of course) distribution. This is an active project (so the Github version is likely to have more bells and whistles for later devices) to provide the functionality for pairing devices and other product features that Logitech don't provide themselves for non-Win/Mac OSes...! There are both GUI and CLI versions in the software.

  • Thanks for the bounty - sadly, that stopped me getting a "This is Fine" secret hat in the 2016 WinterBash... but thems the breaks... 8-)
    – SlySven
    Commented Dec 25, 2016 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.