I broke my boot partition and had to rebuild it. Both cmdline and config.txt are gone and I had to start over. The rest of the system is untouched. Unfortunately, I forgot how they were configured and now aplay (and therefore mpd) find no soundcards.

I think I missconfigured my /boot/config.txt. My goal is to have a resolution of 800x480 60p and to have mpd as well as kodi use an external USB soundcard.



hdmi_cvt=800 480 60 6

Unfortunately I still get no sound: sudo aplay -l results in aplay: device_list:268: no soundcards found...

Since I didn't touch any config files outside /boot, I think the error must be in the file posted above.

Update: I was able to reproduce the behavior on a different Raspi. There I backed up the files config and cmdline, but exactly the same thing happened.

Update: The USB-attached wireless keyboard is not working either. It may be an USB-related problem. What's strange is that all devices show up in lsusb.

What is the problem with it? Thanks in advance!


Solution: Install updates again. The problem with MPD and the USB keyboard was due to a bug in a packet that got installed along with the update (maybe the kernel, but I don't know). It was unrelated to the boot files. Today's updates solved the problem. Everything is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.