1

I have my Raspberry Pi hooked up to an old Philips HD ready FlatTV. I have my XBOX360 working over the HDMI -> DVI cable, and it is using these settings:

1280x720
Breedbeeld (Widescreen)
DVI+A

I have been fiddling now with the config.txt file with mixed results, but none of them seem to really work. The best I have got now is this setting:

hdmi_group=2
hdmi_mode=0x55
hdmi_drive=2

With these settings, I get some text-mode bootup messages, but once the Pi is booted, the screen stays blank.

  • @goldilocks still nothing. I have to say though, the setting that worked yesterday also doesn't work today .... – Bart Friederichs Dec 18 '16 at 14:16
  • I just noticed the HDMI->DVI cable bit. I think if you look around here you'll find many people have had problems with them either simply because they draw power, or perhaps because of this more subtle issue: raspberrypi.stackexchange.com/a/45050/5538 – goldilocks Dec 18 '16 at 14:20
  • @goldilocks I do get the bootmessages, it just switches back to black after that. Only text mode is fine for my purposes. – Bart Friederichs Dec 18 '16 at 14:21
  • Okay, maybe someone will come along with a more magical solution...if you're getting inconsistent results and you've tried X, Y, and Z, you should really make more of an effort to explain that in detail in the question. Otherwise you are just going to get people repeating what's been said in the other ~30 similar questions (and they are most likely correct, since they all seem to boil down to those same few issues). – goldilocks Dec 18 '16 at 14:24
2

Make connection with raspberry pi through ssh and login with your credentials and then type following command.

sudo raspi-config

Enter your password. And then you get a list some option like this Output of raspi-config command And then go with advanced option. After that, you have to select resolution option. In that go with minimum resolution and save it. And shutdown raspberry pi by command

sudo shutdown -h 0

And now plug your raspberry pi to cable attached to your display(hdmi) and power the raspberry pi. I hope this will helpful for you.

0

I do not know why this works or even has an effect, but the culprit was hostapd, when I start it with

service hostapd start

the image is gone. When stopped, the image appears again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.