I got a new Raspberry Pi 3 model B and it came with NOOBS which allowed me to choose which items I want to install. I chose Raspbian and OSMC and ever since it offers a menu and then automatically boots Raspbian after 10 seconds.

What needs to be done to change the default timeout in seconds before an OS is booted?

Can I skip the boot screen altogether (perhaps with a hotkey to catch it)?

Can I add/remove items to the boot screen?

4 Answers 4

  1. Add bootmenutimeout=5 to /boot/cmdline.txt to change the setting to 5 seconds. Notes for Noobs:

    • Use sudo nano /boot/cmdline.txt to edit the file.
    • Make sure you have a space before you add bootmenutimeout=5 to the end of the line
    • Use Ctrl+X, Y, Enter to save and exit
  2. The boot screen cannot be skipped automatically unless there is only on OS installed. You could set the timeout above to 1s. Haven't tried 0.

  3. You can do a quick and dirty removal of an OS by removing it from the file /media/pi/SETTINGS/installed_os.json. Noob notes:

    • Use sudo nano /media/pi/SETTINGS/installed_os.json to edit the NOOBS menu
    • Find the section between the {} brackets referring to your OS
    • Note the partition numbers (e.g. /dev/mmcblk0p6 and /dev/mmcblk0p7)
    • Remove that section as well as the comma on the line before your {. So remove your section and ensure you have } and not }, before your removed section
    • Ctrl+X, Y, Enter to save
    • You can now reboot or run sudo cfdisk /dev/mmcblk0 to delete the partition numbers noted above
    • Reboot and the OS should be gone, here's where you might wish you had backed up your installed_os.json file first!
    • To actually regain the lost space is very tricky and not attempted here!
  4. You can add an OS by rebooting and holding Shift untill you reach the NOOBS recovery menu. Select a new OS and install it.


See this answer. Basically, there's a file at /boot/config.txt where you can set boot delays in seconds (boot_delay=) or miliseconds (boot_delay_ms=)

  • This won't do it. According to the docs[1] the boot_delay is just a delay giving hardware a chance to start. It has nothing to do with the timeout of the boot menu. I think boot_delay applies to the pi before it even gets to the boot menu. [1]raspberrypi.org/documentation/configuration/config-txt.md
    – Marc
    Dec 20, 2016 at 9:03

I would suggest you check out the NOOBS advanced documentation which is stored with the github sources.




Try this documentation for BerryBoot. There's two text files cmdline.txt and config.txt that have options in them, including bootmenutimeout=<seconds>. Change that option to nobootmenutimeout.

According to this answer, these 2 text files should be located in the root of your main partition.

  • Sorry, I've since discovered it's definitely NOOBS and updated the question,.
    – Marc
    Jan 4, 2017 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.