enter image description hereI would like to enable my camera in my Raspberry.

But when I go to sudo raspi-config, I don't have an option to enable/disable my camera. I've already tried to upgrade and reboot my Pi, but it doesn't seem to work.

Anyone who could help me out?

  • I am assuming you mean a Pi-cam? – Steve Robillard Dec 20 '16 at 2:40
  • Could you show your raspi-config menu screen? Screenshot or a photo. – techraf Dec 20 '16 at 4:07
  • Welcome to the Raspberry Pi flavoured corner of the Stack Exchange network. You say you've already tried to upgrade, do you literally mean just sudo apt-get upgrade or did you mean sudo apt-get update - the former means the bigger step to go from one version of (presumably) Raspbian to another which does not happen very often whereas the latter means the smaller step to make sure to get the latest updated versions for the current version of the Distribution and is probably more likely to produce some action...! – SlySven Dec 20 '16 at 4:13
  • I've uploaded a screenshot of my sudo raspi-config, – Julien Ostyn Dec 20 '16 at 21:20
  • 2
    Can you upload a screenshot of 5 and 7 interfacing and advanced options. The camera is likely under number 5 which you can get to by using the arrow keys on the keyboard. and the enter key to select. – Steve Robillard Dec 21 '16 at 19:01

The option to enable the camera is in the "Interfacing Options" submenu. It will be clearly labelled ("Enable/disable connection to the Raspberry Pi Camera").


You will find the enable camera option in interfacing options.Thanks


Not the answer you're looking for? Browse other questions tagged or ask your own question.