2

So I have on hand a 3g usb dongle that I'm trying to get connected to the raspberry pi, I've used the process described in: https://www.thefanclub.co.za/how-to/how-setup-usb-3g-modem-raspberry-pi-using-usbmodeswitch-and-wvdial

and I've found that I don't need to use the usb_modeswitch (the dongle's vid/pid is 05c6:6000, from qualcomm Siemens sg75, seems to be recognized as a modem right off the bat, which is nice (confirmed using nmcli))

However when I'm running the wvdial 3gconnect command the AT commands get sent sucessfully, I'm able to get connected to virgin mobile, but pppd hangs up after returning garbled characters with error code 16...

since I'm running it off the raspberry pi usb port, I've tried buffering it for higher current from the recommendation here (using a 7805 that can provide 1.5A): https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=71114 but it didn't change anything.

Previously I've also tried to use saskis3g, however it always returned an "Error when querying for pin" though at that point I hadn't buffered it for higher current

Does anybody have any idea what I can try to get it working? The 3g dongle is what looks to be a rebranded Huwawei E173, I ordered the E173 from amazon but they sent over a rebranded version...

The output from running wvdial 3gconnect is below:

--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","inet.bell.ca"
AT+CGDCONT=1,"IP","inet.bell.ca"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Dec 20 18:43:44 2016
--> Pid of pppd: 967
--> Using interface ppp0
--> pppd: ȱh[01]h�h[01]��h[01]
--> pppd: ȱh[01]h�h[01]��h[01]
--> pppd: ȱh[01]h�h[01]��h[01]
--> pppd: ȱh[01]h�h[01]��h[01]
--> pppd: ȱh[01]h�h[01]��h[01]
--> pppd: ȱh[01]h�h[01]��h[01]
--> Disconnecting at Tue Dec 20 18:45:01 2016
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.