2

I'm using a raspberry pi for a project. It's equipped with a 7 inch LCD touch display. I'm running a QT-application without a display manager.

I've edited /etc/rc.local with the following line: "su -c startx pi&" and the /home/pi/.xinitrc contains "/home/pi/bin/0027". This all works, the pi starts up and the application 0027 is loading without a display manager.

The problem is that the LCD blanks after 10 minutes, regardless of the things I've tried.

I've tried the following:

In the file /etc/kbd/config I've changed to the following: BLANK_TIME=0 POWERDOWN_TIME=0 BLANK_DPMS=off

In the file /boot/cmdline.txt I've added "consoleblank=0"

In the file /etc/xdg/lxsession/LXDE/autostart, I've added: @xset s noblank @xset s off @xset -dpms

In the file /etc/lightdm/lightdm.conf after [SeatDefault] I added "xserver-command=X -s 0 dpms"

Nothing helps, the screen blanks after 10 minutes no matter what! I've read that 10 minutes is the kernel default, so I seems that all other settings are ignored. Is this due to the fact that I doesn't use a display manager?

Any ideas would be highly appreciated!

Thanks in advance!!

1

There was no problem with Raspbian, the problem was the QT-app.

By mistake I compiled it as debug, and that caused this problem. I recompiled it as release and the problem is gone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.