2

On the motherboard of my Pi is written 'Raspberry Pi 3 Model B v1.2'. I was under the impression that Raspberry Pi 3 had a built-in Wifi interface. I installed Raspbian using NOOBS and ran the ifconfig command. The only adapters that show are eth0 and lo.

Does this version not come with a WiFi adapter or have I missed some required setup? My Bluetooth adapter is also not visible - when I click on the Bluetooth icon in the menu bar it says `No Bluetooth adapter found'.

Any help would be much appreciated, thanks!

  • Very probably you have insufficient power going to it. You need a better charger. – Mike Dec 23 '16 at 14:37
  • try if 'iwconfig' shows the adapter – Gotschi Dec 23 '16 at 15:26
2

I've found that most of my chargers don't provide enough power to my PI3, even if the "under-voltage" icon doesn't show up. This causes the Wifi and Bluetooth to be disabled in an otherwise working system. An original Apple iPad charger did the trick.

  • Hi Mike, when I first tried to figure out what was wrong I came across several people saying that in forums so I ordered the official Pi PSU (5.1v, 2.5A), and still no luck! – petehallw Dec 23 '16 at 16:45
  • We'll, a defective pi isn't common but also not unheard of... I suggest you send it back. It's a bummer but less than having something that "half works". – Mike Dec 24 '16 at 11:27
  • Just FYI and anyone else stumbling across this - the Pi was faulty (i.e. don't waste hours of your time as it should work out of the box...). I swapped my OS loaded SD card into a colleague's Pi, of the exact same model, and it worked perfectly without any extra steps. – petehallw Jan 6 '17 at 15:10
  • @petehallw I've seen dire warnings that jostling the WiFi chip while installing the Pi in a case can kill WiFi. – arp Apr 20 '17 at 11:51
0

How do I set up networking/WiFi/Static IP describes the setup methods.If these do not work you may have a faulty download, and I suggest you try again.

Did you check the checksum of the download?

As you have not indicated what you have possibly tried, no one can know.

  • I downloaded the OS twice and had no luck with the WiFi/Bluetooth adapters. I've not tried anything thus far, simply booted my Pi and checked for wlan0. Supposedly it should work out of the box with a new install of Raspbian but that's not been the case for me unfortunately.. – petehallw Dec 22 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.