My Pi has Raspbian Jessie and it is behind my college's proxy server. I am able connect to the internet and download packages.

I even tried doing export http_proxy=user:pwd@proxy:port

I am not able to access any website using Chromium browser.

  • IIRC In the settings menu under settings (under advanced settings) you can configure the proxy settings. – Steve Robillard Dec 22 '16 at 15:52

Changing the proxy settings is in chromium is normally not necessary since they are picked up from the system.

However, assuming you have already rebooted and restarted chromium, and it still is not working. You can configure the proxy settings for Chromium by clicking the menu (three vertical dots to the right of the address bar), and selecting settings. Then scroll to the bottom of the page and click Show advanced settings. Under the Network heading click Change proxy settings You can also configure the settings from the command line. Use the following command:

man chromium-browser

to get the specifics.

  • 1
    I am trying to configure using command line. So I typed this, $ chromium-browser --proxy-server="proxy:port" Where do I give my user name and password? – Abhilash A Dec 23 '16 at 4:25
  • @AbhilashA I would assume right on the commandline – Steve Robillard Dec 23 '16 at 8:48

Use the following command in terminal
chromium-browser --proxy-server="proxy_ipaddress:port"
Kudos new browser will open with proxy bypass.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.