2

I was recently updating my Pi when I accidentally interrupted the process by shutting down my notebook. I cannot login now and when I tried to reboot the Pi is going into an emergency mode. After entering this mode I tried sudo dpkg --configure -a which showed me a page where it asked me to choose a new php.ini or keep the old one. When I chose to keep the old one, the program returned to the prompt and then wouldn't accept any commands.

I followed a thread where it asked the OP to remove the SD card and do a fsck check on another linux machine, which I did. It removed a few bad clusters but this did not help. Also in the emergency mode when I key in systemctl default it does not go back to a normal boot mode and instead shows hangup on the prompt and then does not accept any further commands.

How do I resolve this?

  • 1
    probably not what you want to hear but reflash the SD card and restore from your backup? Take this as a learning moment and reconsider your power options and your backup plan. – Steve Robillard Dec 23 '16 at 13:08
3

I think I've resolved this. At the point where I thought the Pi was not accepting any commands, as it turns out it was accepting them. It just didn't show them being typed on the screen. After running fsck on the disks I ran dpkg reconfigure and it seemed to fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.