2

When I plug an SD card into my laptop with the Raspbian image on it, only the boot partition shows up in Finder. It took me a while to figure out that two partitions should be seen instead of only one. I even installed MacFuse and tried Linux virtual machine yet the Linux partition of the image cannot be seen. I did test the card multiple times with a Windows/Linux machine which shows that the card is OK (two partitions). What could possibly be the reason for the partition not showing up? Needless to say, macfuse doesn't work. Interestingly diskutil list does show the partitions (where one is called 'Linux' with NTFS file system) but when I mount it, I still can't see files on it (diskutil mountDisk or ext2-fuse). disukutil list:

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *31.9 GB    disk2
   1:             Windows_FAT_32 boot                    66.1 MB    disk2s1
   2:                      Linux                         4.3 GB     disk2s2

I'm confused a

  • macOS cannot read ext4 partitions (due to SIP). Also most add-ons to enable ext4 no longer work. – Milliways Dec 27 '16 at 22:02
2

Mac's SD-Card reader usually is connected via PCIe, which some programs fail to detect as a valid Drive. (VMWare fusion for example assumes a USB SD-Card reader)

Furthermore, the Partition on your SD Card is ext3/4, which can not be read by native OSX. MacFuse CAN read those File Systems, but maybe not from the SD Card because of mentioned bus connection.

you can try Paragons "ExtFS for Mac", they also offer a 30day trial: https://www.paragon-software.com/home/extfs-mac/

And if you tell us more of what you'd like to achieve in the first place (why mount it on OSX?), maybe i can help you with a workaround.

  • I just want to know why does MacFuse not work. I've tried Paragons, too. No success. It drives me nuts. The Other thing is that I want to be able to edit the RPi image so that I can enable SSH, disable SSH root login, etc. Right now I have to do all of the updates and settings after the Pi boots. – alkopop79 Dec 28 '16 at 6:20
1

After re-installing macfuse (with 'Compatibility layer' option on) and ext2-fuse finally partition is visible and I can edit the Pi's image. In case you see this on the terminal, you need to re-install macfuse with the compatibility layer:

$fuse-ext2 /dev/disk3s2 ~/mnt
dyld: Library not loaded: /usr/local/lib/libosxfuse_i64.2.dylib
  Referenced from: /usr/local/bin/fuse-ext2
  Reason: image not 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.