8

I maintain a distro that runs chromium called FullePageOS.

I added gpu acceleration, but now mp4 video crashes the chromium tab when its viewed (mpeg works).

How can I fix this?
Alternatively how do I figure out exactly what is causing chromium to crash?

More info:

I am using kernel 4.4.34-v7+ and Chromium Version 51.0.2704.91

Its a bug I can see on FullPageOS RC1, here is link to the bug with conversation on github.

Update: Terminal output is:

libGL error: MESA-LOADER: failed to retrieve device information

(chromium-browser:1964): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally without any error message
MESA-LOADER: failed to retrieve device information
MESA-LOADER: failed to retrieve device information
Received signal 8 <unknown> 000000000038
#0 0x00005535e098 base::debug::StackTrace::StackTrace()
#1 0x00005535dfe8 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#2 0x000075b941a0 <unknown>
[end of stack trace]

Steps to reproduce:

  1. Download FullPageOS RC1 (md5) (or you can build devel branch)

  2. Set up wifi/connect to ethernet

  3. After boot vnc, or press ctrl+tab to open a new chromium window (Chromium starts at boot)
  4. Put the URL: https://graftechnology.s3.amazonaws.com/videos/matthew-west-promo-android-tablet9.mp4

Expected: video should play Result: get an "awww snap" page

Notes: if you add the tab to FullPageDashboard, and the tab is not selected, you can hear the video playing, but once you switch to it so it becomes visible it crashes.

Note: I also tried runnign with --enable-logging --v=1 and look in chrome_debug.log, and could not find something about the crash (I am not sure what to grep for)

There is also a thread about this bug in raspberrypi forum

Here is the status of chromium in the gpu tab: output of chrome gpu tab

  • Have you tried to purge and uninstall- reinstall chromeium? sudo apt-get remove chromium then apt-get purge chromium then apt-get install chromium – User98764431 Oct 12 '17 at 14:02
  • This is part of the installation of FullPageOS. it builds it each time. Its not a package problem – GuySoft Oct 15 '17 at 17:44
  • Also update - Chromium 60 seems to be far more stable, I need to test this when I have time. – GuySoft Oct 15 '17 at 17:44
  • 1
    Problem has returned on chromium 65 – InternalFX Jun 3 '18 at 16:21
1

Upgrading from 56.0.2924.84 to 60.0.3112.89 and using Debian Stretch seemed to have solved the problem. You can download a distro and see its working with version 0.8. And how it fails in version 0.7.

Here is the current gpu tab:

GPU tab

Note, there seem to be disabled items in the detected problems, perhaps one of them is the one that cased the crash:

Detected problems section

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.