5

OS is Raspbian Jessie with latest updates. Everything is stock packages, no special configuration either. It just runs eJabberd at the moment.

As of a few days ago, I have stopped being able to connect to my 5GHz wireless network using my Ralink RT5572 wifi dongle. It worked fine for over 6 months. Using the same dongle, I can connect to the 2.4GHz network just fine. However since that frequency is quite full here, I want to use the 5GHz one.

There are three other clients using the 5GHz network and all of them can still connect to it just fine.

The 2.4GHz network SSID is WIFI_NETWORK and the 5GHz one is WIFI_NETWORK_5G. The AP is my TP-Link Archer VR900v with latest official firmware. Channels are automatically selected by the AP on both networks. Both networks have WPA2 Personal (AES) set for security. Everything, even the passwords, is the same on both networks, except of course the SSID and frequencies.

lsusb:

Bus 001 Device 004: ID 148f:5572 Ralink Technology, Corp. RT5572 Wireless Adapter
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

wpa_supplicant.conf:

country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="WIFI_NETWORK_5G"
    psk="XXXXXXXX"
}

Now, if I try to connect to the AP on the 5GHz network, the authentication gets denied by the AP. dmesg shows it gets denied with code=22. The Internet says this means:

Invalid RSN information element capabilities

Which appears to have something to do with the encryption. The settings for that are the same for both networks, however. So that doesn't make much sense to me. The AP itself doesn't appear to log this, though.

  • Did this happen after an update/upgrade? – NULL Jan 4 '17 at 22:56
  • @NULL difficult to say. I update the Pi on a regular basis but it could have been offline for some time (days) without me noticing, since it isn't doing anything critical right now. – Anpan Jan 5 '17 at 18:16
  • Did you get this fixed? Did you try the dongle on other machines? – not2qubit Jan 11 '18 at 6:56
0

I am not sure why this suddenly stopped working but the following might work:

sudo apt-get install firmware-linux-nonfree crda

sudo iw reg set US or whatever your region is

sudo reboot
  • I tried this and it didn't work, sadly. It has been running on the 2.4GHz band for a while now, but with bad performance due to heavy use in the area. Region is DE. The other 5GHz clients continue to work without problems. – Anpan Jan 5 '17 at 18:13
  • @Anpan Just want to make sure... did you also install firmware-linux-nonfree and crda? – NULL Jan 5 '17 at 18:16
  • Indeed I did. I am almost certain that I didn't have to install firmware initially tho. The dongle worked out of the box. – Anpan Jan 5 '17 at 18:19
0

Something overwrote your supplicant config, you need to reset it:

The configs below also set a manual IP at 192.168.1.60.

/etc/network/interfaces:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
address 192.168.1.60
netmask 255.255.255.0
gateway 192.168.1.1
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

/etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="replace_with_your_ssid"
psk="replace_with_your_password"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
auth_alg=OPEN
}

Then I installed wicd and wicd-curses with the following commands:

sudo apt-get install wicd sudo apt-get install wicd-curses Run wicd-curses at the command line and setup your wireless network and let it automatically connect to this network on startup.

Reboot and I was able to connect to my wireless network.

  • This unfortunately doesn't work either. I even checked if iwlist wlan0 scan lists those capabilities. It does and it also shows both networks with the exact same capabilities, yet refuses with code 22 on the 5GHz one. I have just about given up now. – Anpan Feb 6 '17 at 21:33
-2

Recently Raspberry Pi has some security concerns with WiFi Connection; don't know why; but there is always a solution for any problem. First of all type sudo iwlist wlan0 scan in your RPi terminal and look if your router is listed or not. If it is listed then great and you are nearly done with setting up your network. Type sudo nano /etc/wpa_supplicant/wpa_supplicant.conf and go to the bottom of this file and paste

network={
    ssid="your_ESSID_Name"
    psk="Your_wifi_password"
}

and leave a blank line at the end. Hint you will type both your ssid and psk between the double quotes. Now save the file by pressing Ctrl+X then Y, then finally press Enter. I would recommend that you type the following command to reconfigure your WiFi sudo wpa_cli reconfigure. You can verify that you are connected by executing ifconfig wlan0. If the inet addr field has an address beside it, the Pi has connected to the network. If not, check your password and ESSID are correct, and consider rebooting the RPi. If all the above doesn't work for you. Try checking the official RPi website for Setting WiFi Up Via the Command Line Inteface.

It would be great to try this solution on a very fresh image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.