1

My son and I are complete newbies when it comes to pi and Raspbian. We've just bought a pi 3 and have set up Raspbian from Noobs. We can connect to our router using both WiFi and Ethernet but cannot connect to any sites using the browser. The router is working normally with other devices. I'm inclined to think the pi is faulty, but looking for suggestions to try before I send it back.

  • If you can connect to the router via Ethernet and WiFI it is highly unlikely that the Pi is defective. How did you configure the network? What is the output of ping 8.8.8.8? what is the output of ping google.com? How do you know you can connect to the router? Please edit your question and add the above details - do not add them to the comments. – Steve Robillard Dec 29 '16 at 23:14
  • I had try to reinstall follow this tutorial: Setup Raspberry Pi Without a Monitor, Keyboard or HDMI Cable After reinstall and repair ethernet cable. My raspberry can access internet. Please check ethernet cable. My problem come from my cable. – vanquoc12b4 Apr 29 '18 at 15:25
1

I'm sorry to hear that you're having issues using your Pi, but again it is highly unlikely it is defective. Try connecting a display to it, as well as any USB keyboard. Once you have done that, startup your Pi by connecting any Micro-USB cable to your Pi. If you cannot connect a display to your Pi, connect it to your router via Ethernet and connect it to your keyboard and power supply.

  • Type sudo apt-get install ssh

Download and install Putty, and I recommend using Fing on the App store to locate your Pi's IP address. When that's done, insert the IP address of your PI into Putty, and continue on to the next steps.

Login (if prompted):

Username: pi

Password: raspberry

Type:

  • sudo nano /etc/network/interfaces

Make sure your screen looks like this, if not type it in. step1 tutorial

When you're done doing that, press Control+X, type y, and press enter.

Now, for the final part, type:

  • sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

This time, add the following to the file:

network={
    ssid="Network Name"
    psk="Network Password"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
}

Tip: the name and password is case sensitive, so type it exactly as it appears.

When you're done, press Control+X, type y, and press enter again.

Now you're ready, type sudo reboot now and enjoy your internet-connected Pi!

  • I don't think sudo apt-get install ssh is necessary. – Gene Dela Rosa Jan 30 '17 at 16:40
  • It is only if they want SSH later for remote usage. For this, it is used to connect it to the internet. – Cody Bennett Feb 7 '17 at 9:46
  • Pandalion98, you would be correct. It is installed and enabled by default currently. – Cody Bennett Oct 3 '17 at 18:46
  • Well, that reply took a while. If I'm not mistaken, "currently" is still not quite right, since ssh has been installed by default ever since. An update might be in order though, since by default currently, ssh is disabled unless you do this: learn.adafruit.com/adafruits-raspberry-pi-lesson-6-using-ssh/… – Gene Dela Rosa Oct 4 '17 at 8:28
  • I was providing instructions for installing SSH which was redundant due to its inclusion in Raspbian. You would not be mistaken since I didn't realize you had to enable SSH. You would enable this in raspi-config. – Cody Bennett Oct 5 '17 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.