0

I want to use VNC on my rpi3, in the documentation says that vnc viewer is preinstalled but I don't find VNC graphically and even in terminal (via SSH). I have a multi boot (raspbian, osmc and retropie) that I got here.

Really need help to use VNC on my rpii what can I do ?

  • What version of Raspbian are you running and when did you install it? VNC is only installed on recent versions. – Steve Robillard Dec 30 '16 at 0:48
  • Thanks for trying to helping me: Linux raspberrypi 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux – Solidus Dec 30 '16 at 0:55
  • That does not look like the latest version. try this sudo apt-get install realVNC-VNC-server – Steve Robillard Dec 30 '16 at 1:12
  • Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: gnupg2 : Depends: gnupg-agent (= 2.0.26-6) but 2.0.26-6+deb8u1 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). – Solidus Dec 30 '16 at 1:13
  • I had a lot of time this error while i'm trying queries (I'm not very good at terminal commands) – Solidus Dec 30 '16 at 1:14
0

First of all, a VNC viewer or client, is different from a server. A server mirrors its display to the client.

diagram

To install a VNC server on your Pi, type

  • sudo apt-get install tightvncserver

This worked for me, and I recommend tightvnc java client here: http://www.tightvnc.com/download/2.8.3/tvnjviewer-2.8.3-bin-gnugpl.zip

-edit: I meant tightvncserver, sorry about the confusion.

  • Thanks for your answer, but it says: 'E: Unable to locate package realvncserver' – Solidus Dec 30 '16 at 1:51
  • Sorry about that, I meant tightvncserver. – Cody Bennett Dec 30 '16 at 1:52
  • This answer is confusing. The VNC server included in recent Raspbian (to which the OP's link refers) is RealVNC, which is incompatible with tightvncserver. They have a number of significant differences. Personally I use tightvncserver, but the instructions are not applicable to tightvncserver. – Milliways Dec 30 '16 at 2:54
  • Well, the RealVNC app works with the tightvncserver, I personally use it when I want to quickly checkup on my Pi from my Android Smartphone. – Cody Bennett Dec 30 '16 at 2:58
2

This has been marked as solved however the answer doesn't answer the question. You should do

sudo raspi-config

If you don't see "Interfacing Options" then head to update. Once it's updated, reboot. Then do sudo raspi-config again and go to interfacing options and enable VNC. Reboot once more and it should be working.

1

Download VNC server from https://www.realvnc.com/en/connect/download/vnc/raspberrypi/

and install manually with sudo dpkg --install filename

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.