i just got the Rapberry Pi recently. i was attempting to install a vnc program. so i am trying several ways to get the "ARM" file to install and its not working. is there a default permission,.. because "permission denied" happened when i tried to "./" over an ssh connection. what is the correct way to install this thing?


i must say that online i came across: "sudo raspi-config" and their picture had a an option "vnc" to turn on or off and my machine there wasn't that option. is that maybe stopping the machine from install this?

1 Answer 1


The newest version of Raspbian ships with RealVNC installed and only needs to be enabled via raspi-config or the graphical menu. If you are not seeing this option it is clear you have an older version of Raspbian.

To install RealVNC use the following command:

sudo apt-get install realVNC-VNC-server

Note the use of sudo which will give you temporary root permission to install the software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.