1

I'm trying to watch serial ports.

For that I need the serial port address, but... on the network people's says that address follow unix pattern, like this "/dev/ttyUSB0", but if I enter on raspbian terminal and type.

ls /dev/ttyUSB*

I recieve this mesage

ls: cannot access /dev/ttyUSB*: No such file or directory

I've already tried PySerial, but when i ran the script, the terminal return me an huge error saying what the serial port doesn't exist.

I need some help, I want get away of this problem faster possible.

  • That comes up for me sometimes so I searched. No clean way, but "dmsg | grep tty' seems to work – PaulF8080 Jan 5 '17 at 22:25
1

The name given to the serial port depends principally on how but also on what you have connected.

If you connect a 3.3V safe TTL serial link to the Pi's GPIO (pins 8/10) then the serial port is called /dev/ttyAMA0 or (rarely) /dev/ttyS0. On Raspbian you should preferentially use the link /dev/serial0.

If you connect via a USB dongle plugged in to the Pi the serial port will normally be named /dev/ttyUSB0 for the first, /dev/ttyUSB1 for the second etc. An exception is if the other end of the dongle is connected to an Arduino in which case the port is likely to be named /dev/ttyACM0.

  • I did it, I connected an Arduino in one USB port, and the /dev/ttyUSB0 appeared. – lambda Dec 31 '16 at 14:14
  • Its so confusing all these port names ... – Piotr Kula Jan 5 '17 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.