I have a brand new Raspberry Pi3. I had it connected to an hdmi monitor when I installed it, and VNC worked great. I am planning to use it without a monitor, and now when I restart without the monitor, it's dimensions are tiny. How to I get full screen in VNC even after reboot?

I'm using the default VNC Server that came with NOOBS:

enter image description here

  • Which VNC server do you use?
    – techraf
    Jan 2, 2017 at 3:49
  • @techraf VNC Server 5.3.2
    – Daryl
    Jan 2, 2017 at 5:08
  • If you have not already setup for headless see:- realvnc.com/docs/raspberry-pi.html#raspberry-pi-virtual. RealVNC is probably OK if you want to view the same screen on the Pi and your laptop (and use their proprietary viewer), but IMO tightvncserver is more appropriate for headless use.
    – Milliways
    Jan 2, 2017 at 5:47
  • @Milliways I'd be fine with a virtual desktop, if there was a way to automatically create them on reboot. That isn't listed anywhere in that url, so I'm guessing its not possible?
    – Daryl
    Jan 2, 2017 at 6:08
  • I can't help with RealVNC (I find their instructions confusing). I use tightvnc which I start on boot. See Start VNC on Jessie at boot to start TightVNC. You need to install sudo apt install tightvncserver (which replaces RealVNC).
    – Milliways
    Jan 2, 2017 at 6:47

2 Answers 2


As you are Using the New VNC for Raspberry PI , Make sure you Have Latest VNC on your Client PC. then

  1. open your VNC Viewer
  2. Right Click on your Raspberry pi
  3. Click Properties
  4. Go to Options
  5. . Scaling to Fit to Windows or as you want

Got the following link and it will explain how to change the "config.txt" file to resize your VNC screen when using the RPi without a display. I had the same problem and this fixed it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.