0

I am using SSH and PuTTY for SSH terminal access; FileZilla works well for sftp file transfers.

I've installed tightvncserver for desktop access.

sudo apt-get-install tightvncserver
sudo vncserver :1
  (entered 8-character password, no password for view-only)

Also installed xrdp for Windows Remote Desktop access.

sudo apt-get install xrdp

Apache2 is installed and I can work on what it presents in /var/www

Zenmap on Windows shows the following ports:

22/tcp   open  ssh
80/tcp   open  http
3389/tcp open  ms-wbt-server

I have shut down and taken out the SD card and used Win32DiskImager to save an image of the system on my Win7 file server, then put the SD card back in and started up, and am running it as a headless system using Windows Remote Desktop in lieu of a dedicated HDMI display and keyboard.

Everything is working very well.

My question is: How can I set up an anonymous FTP server on port 21 so users on my private LAN can access daily summary files for download access without any login prompt or any other impediment to their access?

  • 4
    I edited the irrelevant details out of the question -- you forgot, "First I ordered a Raspberry Pi on _____.com, paid via PayPal. It took 8 days to arrive, then I took it out of the box and attached an Acme 5V 2.A supply to a wall socket in my living room near the window... The pi is in a black case... It was raining last Sunday..." – goldilocks Jan 2 '17 at 15:43
  • Ha. It was indeed raining on Sunday, but I bought the unit a couple of weeks ago. My bad. ;-) – SDsolar Jan 2 '17 at 16:17
1

ANSWER:

First, I found in the Raspberry Pi documentation the recommendation to use pure-ftpd. So I tried it, and it turns out to be complicated to get it installed, and once it was in my Firefox and Internet Explorer users could accomplish anonymous logins with minimal fuss, but Chrome insisted on prompting for a username and password every time. Not going to work here, as most use Chrome. Uninstall. Good riddance.

Then the next step is to try vsftpd.

cd       (go to home directory)
mkdir ftp
sudo apt-get install vsftpd
sudo leafpad /etc/vsftpd.conf
  listen_ipv6=NO            <- change from YES
  anonymous_enable=YES      <- change from NO
  anon_root=/home/pi/ftp    <- add this line
  local_umask=022           <- remove #
sudo service vsftpd restart
-put some files in the ftp directory-

Now Zenmap shows:

21/tcp   open  ftp
22/tcp   open  ssh
80/tcp   open  http
3389/tcp open  ms-wbt-server

and voila - it works from all browsers, and just takes a few minutes to install.

Everything else is working the same. Just as intended.

Problem solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.