I set up a raspberry pi to run as a dash/infoboard.

To do this, i used midori and uncutter(to remove the cursor) and start it up from the ~/.bashrc file, like so

startx /usr/bin/midori http://google.com
@uncutter -idle 0.1 -root

But what every i try, i can't stop the screen from going blank.

Can anyone help me with this? i been looking at many solutions on the internet, an none worked for me,

The things i tried is.

  1. LXDE Autostart
  2. Disbale in rc.local
  3. Disable in xinitrc

Thanks for your time

  • Putting GUI commands in .bashrc is a very bad idea; any instructions you are following which recommend this should be ignored as if they never existed.
    – goldilocks
    Commented Jan 3, 2017 at 15:44
  • Whats your take then? If you had a clean pi with raspbain jessie lite, how would you make a dashboard?
    – DaCh
    Commented Jan 4, 2017 at 8:06
  • You should look up what .bashrc is for and consider why using that this way is an idea spread by -- no exaggeration, no offence -- morons. Probably a more common term for dash/infoboard is "kiosk" and where I'd start is described here: raspberrypi.stackexchange.com/a/57565/5538
    – goldilocks
    Commented Jan 4, 2017 at 10:08

4 Answers 4


To prevent the screen from going blank try adding consoleblank=0 to the end of the first line of /boot/cmdline.txt



A common console command which works on every Linux instance I worked with is

xset s off -dpms

The s off part means "turn off screensaver", and -dpms prevents DPMS standby/suspend modes.

The equivalent configuration can be done via xorg.conf using

Option "DPMS"        "false"
Option "BlankTime"   "0"

Those options should go to Monitor and ServerLayout sections, respectively.

  • 1
    Adding the options to the xorg.conf helped. Everything else was launching this annoying blank screen after two minutes or so. Commented Oct 12, 2019 at 22:10

Running Raspbian Jesse Lite (no X11) on an A+ I too struggled to disable the screen automatically blanking. I suspect that it is related to this bug.

From this forum I found entering the command linesudo sh -c "TERM=linux setterm -blank 0 >/dev/tty0" (or booting with setterm -blank 0 in .bashrc) worked for me.


After trying everything i could thing of, i went back and install scrennly insted.

Not the answer you're looking for? Browse other questions tagged or ask your own question.