3

I have my Raspi 3 connected with an HDMI cable, but the picture is totally blurred. The screen is a 4k screen from AOC. I tried to change the resulution in the /boot/config.txt file, but it didn't helped. Also after I rebooted the Raspi I couldn't open the config.txt file again.

EDIT: I tried the steps from here: https://stackoverflow.com/questions/22891235/how-to-change-screen-resolution-of-raspberry-pi

2
  • You need to provide details about how you "tried to change the resulution in the /boot/config.txt" and in what context you "couldn't open the config.txt file again".
    – goldilocks
    Jan 4 '17 at 14:18
  • You should probably try xrandr Jan 5 '17 at 17:20
2

If you are not sure what what values you should put into /boot/config.txt under hdmi_mode and hdmi_group you can first try different values with tvservice.

You should use tvservice -m DMT and tvservice -m CEA to get a list of available modes.

Next try using --explicit="GROUP MODE DRIVE" to set the chosen values.
Example: tvservice --explicit="DMT 81 HDMI" to set it to mode 81: 1366x768 @ 60Hz 16:9, clock:85MHz progressive


Another thing you can try is to enable only the "safe mode" by uncommenting only hdmi_safe=1 in /boot/config.txt

1

The following link has all of the settings for the RPi's config.txt file. There is a section dedicated to the display settings that might help.

https://www.raspberrypi.org/documentation/configuration/config-txt.md

Also, you can modify the config.txt file from any PC or Mac by using an SD card reader. You can locate the file on the SD card (/boot/config.txt), modify it then reinsert the SD card in to the RPi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.