0

So first, some background information about what has happened so far.

I've been struggling to get this thing working stable for a while now and haven't had much luck on my RPI 3. It's Wired in via Ethernet directly into the Router, and has a direct link to the internet of 50/50 Mbps down and up (rock solid connection, not the problem). I know that there are some similar questions floating around here but none seem to really match the symptoms I'm experiencing or I've noticed that I'm having mixed symptoms from the various threads on the internet.

Anyways, I was trying to make my Pi a 24/7 seedbox for Various Linux-y torrents since I couldn't keep my regular PC running all nightMy Test Torrents

So in the very beginning, I had my Pi setup as a small Plex Media Server with my Media library in the SD card. Anyways, I started out by following the How To Geek guide which seems like is what most people start with, and because it seemed simplest. I had a simple 16GB (Fat32) flash drive plugged into one of the USB 2.0 ports of the Pi 3. (which is recognized as a local HDD everywhere for some reason) that I had mounted to /media/USBHDD1. Following the guide was easy enough, and I made these directories with the following:

sudo mkdir /media/USBHDD1/Shared/T/downloading
sudo mkdir /media/USBHDD1/Shared/T/completed
sudo mkdir /media/USBHDD1/Shared/T/watch
sudo mkdir /media/USBHDD1/Shared/T/torrent-backups

I continued following the tutorial (all with the user still being the default user "Pi" over SSH) to set it up as a remote connection to my main PC to monitor torrents as the guide had shown. I had no problems setting anything up until I realized that neither Deluged nor any other remote program (like FileZilla) could access nor write to those directories, with a "Permission denied" error since that was owned by the 'root' user (Chown (Operation not Permitted), chmod, etc also didn't work at giving 'pi' user control). I just decided to make new directories on the MicroSD card in /home/pi/Downloads/... and that seemed to clear up all of the permission issues.


Now, Deluged is running fine and all except when it doesn't. It constantly disconnects at completely random intervals. Sometimes deluged just crashes, so I setup a cron job to constantly check if it's dead every 2 minutes, as some people suggested. Well, Deluged is also giving me extremely variable speeds that seem to start out high at near max bandwidth (I have 6 MB/s) and then dip to practically 0. This is usually about the time that the above problem occurs, or when Deluged freezes for 5 minutes (not updating speed). The problem is that although sometimes only Deluge dies, sometimes my Pi just completely refuses control at all (rarely happens though). SSH stops working, frozen at random points of the connection process, VNC doesn't ever auth/connect, my Plex server dies, Filezilla stops connecting, and as already mentioned, Deluge on W10 disconnects from the Pi connection, appearing offline:

Pi Offline as seem from Deluge

The Pi itself seems perfectly fine with low resource usage in the Task Manager. After I do manage to re-control the pi by physically rebooting it at it's location (I hate doing this as it is headless in an awkward location to plug a mouse/keyboard to) and restart the deluge manually form the command line in SSH, everything works all right until either this or Deluge crashes again. The strange part is although I followed the above tutorial exactly, it doesn't seem to relaunch Deluge correctly upon start up, forcing my to manually kill it with

sudo pkill deluged

and then start it up again with

deluged

Tolerable but still quite annoying. Anyways, does anyone know why my Pi 3 is doing this? It's a fresh Raspbian install and the IP is set to 192.168.1.22 and although I'm not sure how it's set to that (I think I made it static) but my router has never changed it's IP so that's never been a problem anyways. Other things I've tried so far are:

Different MicroSD card, no change Different Power Supply, still no change Different Pi 3 (fully retrying everything over), still no change

I've also tried various "troubleshooting" things others tried which hadn't worked for me like updating Deluged to 3.1.13 (latest) which didn't change anything, disabled encryption, etc... As you can see I'm at a complete loss of what is giving me all of these problems when everyone else seems to have way less issues. My ISP isn't throttling data and all of the above only happen on the Pi.

One last thing I should mention is that after all of that I tried to setup Transmission, which didn't work as the rpc-whitelist in the settings.json wouldn't actually whitelist any IP's but that's a problem for another day. Any help would be really appreciated.

  • Versions? Also, there's a lot of extra fluff in your question thatisn't really needed, and you have to go through 2/3 of it before you get to your actual problem. – YetAnotherRandomUser Sep 1 at 1:50
  • Also, I've found that the windows UI will hog RAM due to a memory leak if left open for a couple of days. You might not want to keep it open all the time. – YetAnotherRandomUser Sep 1 at 1:51
2

Have you tried using transmission instead? I was getting the same issues as you before I switched over to transmission, possibly because it's much less memory intensive. For me a simple: sudo apt-get install transmission-daemon worked and there are plenty of tutorials online about how to setup and optimize transmission for the raspberry pi. I have it setup on my pi 2 and it often sees speeds of 1MBs over wireless, furthermore the upload speed doesn't oscillate as randomly.

In regard to rpc-whitelist problem (happened to me also!), it is necessary to sudo service transmission-daemon stop then change whitelist settings in settings.json and finally issue a sudo service transmission-daemon start, if you simply call a restart or reload the settings will be erased.

My pi torrent box has been running for four months now without any problems (:

  • That's a bit assuring that I'm not the only one who had this problem... I did try stopping the service etc. like you said, but it still wouldn't work. Trust me I've tried every single combo of stopping/starting that service. Also, to make things worse, all of the tutorials for getting Transmission on a pi are somewhat outdated so it seems like something's changed. Any specific suggestions or tutorials to follow that if I try to resetting Transmission up? – yaman koudmani Jan 21 '17 at 17:30
  • Nope. Still didn't work, but thanks to you, I finally had gotten passed the rpc-whitelist problem. (Now I'm getting "Error: Unable to save resume file: Permission denied" but at this point that's a problem for another day.) – yaman koudmani Jan 28 '17 at 21:50
  • Edit: Woohoo! I bypassed the "Permission Denied" problem and finally got Transmission to work. (I had to run sudo chown -R debian-transmission:debian-transmission /home/pi/Downloads/T/Torrent_complete). I'm leaving this open to see if someone else can figure out the Deluge problem. I gotta say Transmission seems fairly stable so far. – yaman koudmani Jan 29 '17 at 23:06
1

I use Deluge as my torrent box, and one thing that helps me is limiting the number of connections, per torrent as 100, and number of active torrents as 3. So total 300 connections as max. I had 500 at time and my rpi2 crashed, so 300 max connections looks okay to me. So limiting your connections may help. Of course I have 75Mbps connection, and wired connection with router as yours, however I have never seen more than 4MBps speed. But that's okay, as RPI runs 24/7 and my wait is just a little longer. If I need things immediately I can use my Laptop.

  • Didn't work... Still the same issue. I don't know if it's a placebo or something but it doesn't seem to crash as often, though it's far faaar from stable. As for 4MB/s limit you seem to be hitting I think that would be limited by the SD Card's write speed, or maybe because the USB and Ethernet both share the same bus. – yaman koudmani Jan 28 '17 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.