0

I have a problem with my Raspberry Pi 3. When I want to connect to my Raspi, after a few attempts it works, but after while (like 1 minute) it says this error: "Software caused connection abort". I have already added IPQoS cs0 cs0 in SSH config but it didn't work. Any idea how to fix it, please?

0

Try This

I added this to the end of my /etc/ssh/sshd_config file on my raspberry pi, and it seems to have helped keep my connections stable. I don't remember exactly what it does, but it may help you.

# Added to keep sessions up
# Disabled TCPKeepAlive because it was frustrating
# Send an alive message 30 times before judging the connection inactive and closing it
ClientAliveCountMax 30
# Send the alive messages every 30 seconds
ClientAliveInterval 30
# This should total to 30x30 seconds = 15 minutes before inactive sessions are closed
  • Thanks for the advice but it didn't work. :( – Filip Jan 6 '17 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.