0

I see that the service "vncserver-x11-serviced.service" is running at startup-

● vncserver-x11-serviced.service - VNC Server in Service Mode daemon
   Loaded: loaded (/usr/lib/systemd/system/vncserver-x11-serviced.service; enabled)
   Active: inactive (dead) since Sat 2017-01-07 22:19:58 IST; 32s ago
  Process: 724 ExecStart=/usr/bin/vncserver-x11-serviced -fg (code=exited, status=0/SUCCESS)
 Main PID: 724 (code=exited, status=0/SUCCESS)

How do i disable this service, so that it doesnt start automatically at boot?

Please suggest.

  • 1
    I'm going to assume you are running Raspbian Jessie, in which case if you look in the system settings there will be an option to disable the built in VNC. – Darth Vader Jan 7 '17 at 17:27
3

sudo systemctl disable vncserver-x11-serviced should do it

  • yes, i was able to disable it using sudo systemctl disable vncserver-x11-serviced.service ● vncserver-x11-serviced.service - VNC Server in Service Mode daemon Loaded: loaded (/usr/lib/systemd/system/vncserver-x11-serviced.service; disabled) Active: inactive (dead) – Alan Jebakumar Jan 7 '17 at 18:22
  • If you want to re-enable it you can use sudo systemctl enable vncserver-x11-serviced – tobyd Jan 7 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.