I have downloaded Raspbian for my Raspberry Pi Zero from official website and flashed it using Win32DiskImager.

I have followed all the steps on https://gist.github.com/gbaman/975e2db164b3ca2b51ae11e45e8fd40a

1.) Installed Bonjour drivers and made sure it's proccesses are running

2.) Plugged in working USB cable into the "USB" micro USB port of my Pi Zero (cable works for Kindle, Android phones etc. to transfer data)

3.) Green LED was flashing as if it was booting and after cca 30s kept shining green without flickering.

4.) Can't see the device in device manager even as "Others" / Parallel port / USB / Network device... nothing

5.) Used USBLogView. When I plug the Zero in/out no events get logged as if the USB data port does nothing.

6.) It made that "USB flash drive connected" sound on the first boot (nothing on other Zero plug ins). Still didn't show up in device manager/log

Looks like the USB is not working or Raspbian is maybe not working correctly. I don't have mini HDMI cable yet so I can't tell...

Any suggestions on what else I check? (Before I get mini HDMI reduction in few days...)

Looks like I cannot access the logs on the SD card using windows. I'll try Ubuntu CD to check the logs if my card reaeder would work....

3 Answers 3


I have crawled a lot of forums with the solution below.

The main issue encountered in Windows 10 is that, the Raspberry Pi Zero maybe identified as USB COM port device.

We have to install a RNDIS driver instead of the auto-installed USB serial port driver.

  1. Download RNDIS driver from here : RNDIS driver, originated from here
    • unzip the file and put them in a [folder1]
  2. Open Device Manager, scroll to Ports (COM&LPT)
  3. Do this step if you do not know which com port your raspi zero is on
    • Unplug and replug your raspi w
  4. Right click the "COM PORT X" and select “Update Driver Software”.
    • Browse my computer for driver software
    • Select the path of [folder1]
    • Install the driver
  5. After successful installation, the "com port" device will be treated as "USB Ethernet/RNDIS gadget"
  6. You can now ping raspberrypi.local
    • So is ssh, if you have completed all procedures for USB-TO-OTG

Sources from:


Your Raspberry Pi Zero takes a little while to boot, and there's a chance that your Windows machine is retrying the USB negotiation while it's doing it. By the time that the Raspberry Pi is ready, Windows may have given up.

I've found the USB OTG network connection to be much more reliable if you power up the Zero from a different USB source (I've tried a power adaptor and a USB power bank), then once it's booted, plug the Zero's data USB cable into the computer. It should be recognized as a network device immediately. If you're feeling brave you can remove the power USB connection as long as the data connection remains attached.

Also: OTG mode can apparently be unreliable going through a USB hub, so try connecting the Zero directly.

  • Thats sounds like it could work. I will give it a try this evening. Thanks! Feb 10, 2017 at 20:29
  • It certainly won't work through a USB hub! USB hubs are client devices, not host devices.
    – Toothbrush
    Mar 27, 2017 at 10:12
  • Maybe anybody is reading this. Did you find any other possibility to deal with this problem? I do not want to first boot my pi with a seperate power source and then connect it via the data port. Is it maybe possible to reset the OTG port after boot so that the computer thinks the device was removed and re-attached? Thx
    – pinas
    Aug 1, 2018 at 13:47
  • 1
    @pinas - it's all down to the USB host's behaviour. If the Raspberry Pi isn't ready and appearing as an OTG device when the host probes it, the host will ignore it
    – scruss
    Aug 5, 2018 at 21:53
  • I asked a similar question seperately and found a - for now - working solution: stackoverflow.com/questions/51632224/…
    – pinas
    Aug 6, 2018 at 14:03

I have tried @MatsK's solution, and it works!

I have made a post and a repo about it with some photos for reference:


I also added the horndis driver to the repo:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.