1

So I am using some 433mhz modules. I had them setup on my raspberry Pi2 and everything worked perfect. They could transmit and receive signals. I switched the entire configuration over to a raspberry pi zero. It uses the exact same sd card, same cords, same everything. However how the transmitter does not work. The receiver still works. I tested switching the GPIO pins being used by the receiver over to the transmitters pins and the transmitter pins over to the receivers pins. Receiver still works and transmitter still fails to work. This is how I know there are no issues with the GPIO pins on the Pi Zero. I thought maybe its something to do with not enough power to transmit but I am using the same power supply and I tested putting the transmitter rate next to the component that was receiving the signal. This had no effect. Normally it can transmit around 50 feet depending on the amount of walls in the way. So what's different between the Pi Zero and Pi 2 that I am missing.

  • You could use my piscope to confirm that the GPIO is actually transmitting. – joan Jan 7 '17 at 22:48
  • How do you know the receiver works, if the transmitter doesn't work? Isn't it possible the transmitter works fine, but the receiver is dead? or both are dead? ... Something changed when you moved from RPi2 to RPi0... Have you tried putting it BACK on the RPi2 to verify it still works? – lornix Jan 9 '17 at 7:54
  • @lornix , I have a program which allows me to use the receiver as a sniffer. This allows me to test it with a remote which works on the 433mhz frequency to see if it is receiving the codes. I have switched it between the two pi's multiple times and the same results I outlined continue to persist. Works on Pi2, Zero works with receiver but not transmitter. – user2389345436357 Jan 10 '17 at 20:22
  • I have exactly the same problem. The 433MHz transmitter works fine on RPi2 but as soon as I switch it to RPi Zero it does not transmit anything. I have checked with RTL-SDR dongle and RPi2 signal is strong and clean. When I switch to Zero it does not transmit anything - not even the slightest noise. I tried on 3.3V and on 5V, different pins etc. No luck. Any ideas? – Piotr Feb 12 '17 at 14:06
  • @Piotr I have decided to dig deeper on this. The fact that there is someone beside me having this issue leads me to believe that is has to be a compatability issue between the two boards and not a fluke. I will post a solution if I find one. Out of curiosity what are you using to interface. I am using rpi-rf and python to send my commands. – user2389345436357 Feb 27 '17 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.