1

I’m newbie and I’ve put my best effort to solve this and the following are the steps I've followed,

  1. Installed, RASPBIAN JESSIE WITH PIXE
  2. /etc/network/interfaces, /etc/wpa_supplicant/wpa_supplicant.conf & /etc/dhcpcd.conf are as mentioned & attached.

/etc/network/interfaces,

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

wpa_supplicant.conf,

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
        ssid="YOUR WIFI NETWORK NAME"
        psk="YOUR WIFI PASSWORD"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        id_str="YOUR WIFI NETWORK NAME"
}

dhcpcd.conf,

interface wlan0
static ip_address=192.168.0.103/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

After doing this, I’ve connected raspberry pi to wifi and can remotely access it using VNC player. But in VNC player, I could not connect to any website but I can access my router using 192.168.0.1 (my router). Also, when I take my cursor to wifi symbol over top right corner it shows me that it is associated to my router and configured with ip I’ve mentioned.

I think I’m missing something but I don’t know what it is.

P.S: if I connect using LAN and share my wifi then it works. Also, if I type “ifconfig wlan0” then “inet addr” field has an address beside it and "ifconfig" shows me connected router.

  • Try adding Google's DNS server (8.8.8.8) to your dhcpcd.conf like so: static domain_name_servers=192.168.0.1 8.8.8.8 – G Trawo Jan 8 '17 at 19:46
0

You are using obsolete settings in /etc/network/interfaces. If you are going to put dhcp in /etc/network/interfaces there is no point modifying dhcpcd.conf because dhcp disables dhcpcd.

To fix see How do I set up networking/WiFi/Static IP

NOTE this has nothing to do with your problem (whatever this is - your question is unclear; "connected RSP to wifi" what is a "RSP"?).

If you get rid of the static IP address and connect the Pi to your router (via Ethernet or WiFi) and let the router do its job everything should work.

  • Here, RSP = Raspberry PI. Okay, I will try to solve it using the link you have mentioned. Thanks :) – imbond Jan 9 '17 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.