1

There seems to be a lot of people using the instructions from http://blog.gbaman.info/?p=791 to setup their pi zero. I have tried this myself, but it doesn't seem to work and no one has any recent posts on this. So in an effort to help out everyone with problems similar to mine, I decided to make this post.

If this is in fact a duplicate question, please let me know; however, I haven't seen any yet.


My setup:

  • Macbook Pro, running 10.12.2 Sierra.
  • I have a monitor and can see that everything loads on the pi, after flashing the SD card and editing the files as specified in the first external link.
  • My problem: When I try,

    ssh [email protected]
    

    I get the following back:

    ssh: Could not resolve hostname raspberrypi.local: nodename nor servname provided, or not known
    
8
  • Have you verified that you are writing the os to the Pi correctly? Commented Jan 9, 2017 at 20:42
  • I have a monitor and mini-hdmi cable that shows that the Pi boots to the desktop. I've been taking that as a sign that the os is written properly.
    – Andy
    Commented Jan 10, 2017 at 4:44
  • have you preformed step 4 from the link in your question correctly? Commented Jan 10, 2017 at 6:10
  • I believe so. I'm using TextEdit to make these changes, is it possible it's adding white spaces somewhere in that file without my knowledge?
    – Andy
    Commented Jan 10, 2017 at 17:56
  • It is possible but unlikely and I do recommend that you try a different text editor but if your file looks like the one that the blogs pastebin post does then it is unlikely to be the problem Commented Jan 10, 2017 at 17:58

1 Answer 1

1

What worked for me under 10.11 was:

  1. following this: https://gist.github.com/gbaman/975e2db164b3ca2b51ae11e45e8fd40a — which may be the core of the updated link you gave. Step 3 (creating /boot/ssh) is critical!

  2. No need for HoRNDIS; you just need to set Internet Sharing to share to your RNDIS/Ethernet gadget, as described in the answer here: networking - "RNDIS/Ethernet Gadget" Share Internet - Raspberry Pi Stack Exchange

4
  • When I try to boot the pi with the instructions in both of our links, I don't see the Pi recognized in System Preferences > Network. Do you think this is the issue?
    – Andy
    Commented Jan 9, 2017 at 19:46
  • So after exploring the RNDIS link you posted @scruss, I noticed my network panel shows "USB Ethernet" instead of "RNDIS/Ethernet" is this the same thing?
    – Andy
    Commented Jan 10, 2017 at 4:47
  • Yes, it should be. Give it a try.
    – scruss
    Commented Jan 10, 2017 at 13:22
  • Then yes, i have that set up
    – Andy
    Commented Jan 10, 2017 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.