1

I have setup my Raspberry Pi 3 with Midori, X11-Server, Unclutter and Matchbox.

Created a small bash script that will run midori in full screen mode that is fairly like this one:

#!/bin/sh
unclutter &
matchbox-window-manager &
xinit midori -e Fullscreen -a http://localhost

Whenever this script is ran manually, i.e.

./midori-full-screen

The web page being loaded, works perfectly, but when this script is added to be executed under

/etc/rc.local

After it boots, it loads the page but no image appears.

Because Midori is loading in fullscreen mode I can't see any errors, but by sshing into to I'm able to confirm that Ngnix is running.

Any ideas why this happens? Maybe I'm missing some configuration or something that would make this work.

Notes:

  • SSH Enabled with different password as suggested by Raspberry PI Docs
  • Boot configured to load desktop
  • No fancy scripting language, only HTML, CSS and Javascript.
1

On my Rpi i add the following prefix to any command line i start from shell/cron in order to make it work

DISPLAY=:0 

So a cron script that uses xdotool to send ctrl+f5 to a chromium window looks like the following in order for it to work:

*/5 * * * * DISPLAY=:0 /home/pi/dashboardrefresh.sh > /dev/null 2>&1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.