4

I run Bitcoin on my raspberry pi 3. I have been storing the blockchain on a 128 GB USB SSD drive:

https://www.amazon.com/MyDigitalSSD-SuperSpeed-Portable-External-Storage/dp/B00N0V4JG2

The performance has been great and I've never had any problems. However, the blockchain recently grew too large so I bought the exact same type of drive, just bigger: 512 GB. And now the computer is embarrassingly slow. Operations that take seconds when the drive was small are taking all day now.

The system itself is still running/booting from a 16GB SD card and that hasn't changed.

I've even run hdparm tests on both USB drives-- and the bigger drive is faster!!

Both USB drives were formatted FAT/Master Boot Record on my OSX machine. I've tried copying the 128 GB of data over to the new drive, and I've also tried starting with the 512 GB drive totally empty. I've even tried using a better power supply. I'm totally stumped. What on earth could possibly be slowing down the processor?!

I also am having trouble making partitions and even formatting this drive. However, when I attach the drive my OSX machine I can format it and use it and it works FINE.

1
+50

Your Amazon link has a significant number of reviews that basically says "my drive died".

What I'd try to do first would be to run fsck on the drive again. Make sure to unmount the drive beforehand.

sudo fsck /dev/xxxN, where xxx is the device and N is the affected partition number. Do NOT run it for the whole device (i.e. do not run sudo fsck /dev/xxx).

If it's still the same, I suggest having the drive RMA'd.

As for the slow performance, I presume the OS is trying to write to the drive, but it can't, therefore blocking some operations.

  • This was the most helpful comment, so bounty. However I still can not get a large SSD to run smoothly on the pi. I'm on my second brand: amazon.com/PNY-Elite-480GB-Portable-Solid/dp/B01GQPXB3U/r and I'm going to try a variety of volume formats but so far nothing works as well as the original 128GB drive – pinhead Jan 27 '17 at 17:10
  • @pinhead In my opinion, it's a game of chance. The very first SSD I bought a few years ago broke down in days. I didn't know what to do (since it was my first). I had it replaced under warranty. It was a manufacturing defect. What are the odds? – PNDA Jan 28 '17 at 1:47
0

I don't know what you actually did but you can't format a 512 GB as FAT. The maximum size of FAT32 is 32 GiB and files are limited to 4 GiB.

Larger drives can use exFAT but I am unsure if Raspbian supports these.

In any event any kind of FAT is totally unsuited to a large drive. Use a more sensible format. ext4 is best for Linux, but macOS doesn't support this.

  • The default mkfs is ext2 so I re-formatted the 512 GB drive like that, from the Pi. I then tried copying all the data (over 100GB, using scp command from the 128GB drive mounted on OSX over my home network to the Raspberry Pi, with the 512GB ext2 drive mounted) which took a few hours. Unfortunately, Bitcoin failed with a ton of structure needs cleaning errors (not sure why). So I just erased and re-formatted the 512GB drive and am now re-downloading the blockchain from scratch, which will sadly take a few days. However, the performance is very quick again! – pinhead Jan 15 '17 at 2:56
  • 1
    As far as "what I actually did" -- a quick look at Wiki for FAT32 suggests that max volume size is 2TB (with 512 byte sectors) but clearly the ext2 formatted drive is playing way nicer with the Raspbian system. – pinhead Jan 15 '17 at 2:56
  • ACTUALLY I'm still not out of the woods yet. Even after a repartitioning with fdisk and reformatting to ext2 OR ext4 with mkfs -- the freshly reformatted drive still returns TONS of errors from fsck-- tons of illegal blocks bad extended attribute flag set etc. Do I just have a defective SSD drive? I don't understand why a brand new disk format could have so many issues, before even using it! – pinhead Jan 15 '17 at 16:18
  • 1
    @pinhead it's likely a defective ssd, and that may also be a contributing factor to your ssd speeds as an ssd with a bad block will make attempts to recover it which is very slow. – Mohammad Ali Jan 20 '17 at 5:58
  • 1
    @DmitryGrigoryev I concede I was wrong, based on SD Cards >32GiB which are required to be formatted as exFat (nothing to do with Micro$oft). The 32GiB limit only applies to FAT. Still a dumb idea to use any form of FAT on a 512 GB drive (on any OS post Windows 98). – Milliways Jan 23 '17 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.