I'm working on a system that uses serial for two applications;

1) Reads in from a Maxbotix MB7389 ultrasonic sensor on pin 10 (TX) 2) Communicates (sends) measurement info to a household server through Xbee wireless radio modules

Somewhere along the line, the Raspberry Pi 3 began hanging on reboot, and tons of entries are being dumped into /var/log/daemon.log that I haven't seen before:

Serial-getty error

This is happening at all times that the system is booted, and it seems to be that the process is looping every 18 seconds or so, as can be seen by the timestamps. As far as I can tell, I don't have any software that's triggering this.

Has anyone come across issues that might be the cause of this? I can reimage the card, but would rather avoid it.


Try systemctl disable serial-getty@ttyS0.service. This disables the Linux shell on that serial from autostarting, which is exactly what you need if you want to use the same serial for communicating with your sensors.

| improve this answer | |
  • Thanks for your insight! I wasn't sure if I'd be permitted to disable the service, but I gave it a shot and it doesn't seem to have worked. In the 'daemon.log' file there's a line in there that simply says "Jan 14 18:47:53 raspberrypi systemd[1]: Reloading." And then the issue returns (one second later). That's when it's manually triggered or in the startup .sh file that calls my other python files. – Markus Jan 14 '17 at 18:50
  • What about systemctl stop the same .service unit, too? – Арсений Пичугин Jan 14 '17 at 22:36
  • Two months later, everything seems to be stabilized and sorted. Thank you for your help, and apologies for the (exceptionally) late confirmation that this is solved :) – Markus Mar 14 '17 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.