2

I am trying to install the driver for this: http://www.waveshare.com/wiki/3.5inch_RPi_LCD_(A) on my raspberry pi 3. I'm trying to use method 1.

Whenever I type "./LCD35-show" I get "permission denied" and when I type "sudo ./LCD35-show" I get "command now found". I'm running a clean version of Raspbian. How can I run that one command?

  • It looks like the LCD35-show is missing #!/bin/bash as the first row in the script. – MatsK Jan 15 '18 at 2:58
2

Best bet is to ask the supplier for support since by the looks of this was built for the Pi.

There doesn't like like anything in that script that should cause problems but since it is, a few suggestions that might work.

The blunt approach would be to just run it as root via sudo su then ./LCD35-show and see if that makes it happy. I'd tried this in a Raspbian Jessie Docker container as root after copying in boot and creating some of the directories that you should have if you have have the GUI and the script ran to completion. That said, it worked fine for a normal user + sudo too.

You could try running the command as sudo -e ./LCD35-show in case its relying on some special environment variable, which i can't see... sudo source LCD35-show or sudo bash LCD35-show might work in case the shell isn't quite interpreting the lack of shebang directive at the top correctly.

-2
sudo chmod 755 LCD35-show 

then run

sudo ./LCD35show
  • In the question, the OP writes that the "permission denied" error only occurs without sudo; with sudo the error becomes "command not found". This implies it is not because the file is not executable. – goldilocks Jan 15 '18 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy