1

I am using Debian 8 (Jessie) on my RPi A (previously I was using wheezy). When I try to connect from Windows with BitVise SSH, it refuses and the connection times out, implying there is no such address active on the network.

If I login via keyboard to the RPi, then the address becomes valid and my remote connection will proceed. I have enabled sshd via raspi-config.

I also noted that there's no IP address shown when Pi the boots, as with the previous (Wheezy) install.

Is this normal? Why do I have to seem to have to login physically before the Pi connects to the network?

  • 1
    No, it is not normal that you have to login physically (the part about the IP not being shown at boot now is, though). Why something doesn't work properly is hard to diagnose without access to the machine. You might look through the system logs to see if there are clues about what is happening and when. – goldilocks Jan 21 '17 at 15:50
  • You have provided no information about which OS version, when you installed, how you enabled networking, whether you enabled ssh – Milliways Jan 24 '17 at 11:10
0

As a security feature in Raspbian, newer version of Raspbian has SSH disabled by default. To enable SSH create a file with file name named ssh in boot partition of the SD card using your PC. Then insert the memory card back to the PI. SSH will be enabled.

  • Done and nothing new happend, can't connect remote machine before RPi login, and according with this article here, it's just the same thing as doing sudo raspi-config and activate from there, but it's only useful when you're not in possess of a external keyboard/monitor. – Edilson Jan 15 '17 at 12:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.