5

I am using Raspbian.

The WiFi options are grayed out for University networks but not for home networks. I think this might have something to do with the fact that the school requires username & password, while home networks only need password. Is there a work around to this?

2
  • If you take a gander at the other questions on the site relating to university IT and Pis, you'll likely notice that it's usually a bit of an uphill struggle. Your best bet is to rake through the IT department's help pages (if they exist) and, if that fails, contact them directly. I'd heartily recommend not doing anything too weird or wonderful - uni IT policies can be pretty stiff, and the last thing you want is some helpful soul ejecting you from the building for trying to introduce gaping security holes.
    – goobering
    Commented Jan 16, 2017 at 16:58
  • If you're very lucky, your institution might be registered for an eduroam configuration installer. Hitting the download button at the bottom of the page brings up a list of everyone registered.
    – goobering
    Commented Jan 16, 2017 at 17:01

2 Answers 2

1

you probably need to setup wpa_supplicant.conf in my raspberry it is located at /etc/wpa_supplicant

check this other similar answer

Pi 3 cannot connect to Enterprise WiFi using GUI

0

There are many solutions in the internet that require modifying the wpa_supplicant configuration manually and similar, but this is pretty complex, hard to get right and inflexible when the configuration changes. The "greyed out" issue is because the PIXEL desktop in Raspbian comes with its own simple network managing service that does not support more complex WiFi setups used in enterprise and university networks (especially eduroam).

There is a simple way to fix this though that I haven't found mentioned anywhere else so far: Instead of the Raspbian integrated one you use NetworkManager, which is what's used in most Desktop Linux environments.

sudo apt install network-manager network-manager-gnome
sudo systemctl disable --now dhcpcd
sudo systemctl enable --now network-manager

nm-applet # to show the tray icon without reboot

You have to disable dhcpcd because it conflicts with NetworkManager, otherwise you get a "device not ready" message instead of a list of wifi networks.

This should now show a new tray icon where you can connect to any network like eduroam.

The setup for the enterprise wifis is the same as on any desktop linux (e.g. Ubuntu). For example, for eduroam you use PEAP (Protected EAP) instead of Tunneled TLS, leave anonymous identity domain empty, get the CA certificate depending on your university or set it to "no ca required", PEAP version automatic and inner auth MSCHAPv2.

After a reboot it should auto-connect correctly.

If you do not have a Ethernet cable to install new software before setting up WiFi, you need to look up how to install the network-manager package offline or simpler connect your phone with USB and enable "USB tethering" which works without any setup.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.