3

I want to install NodeSource Node.js v7 on my Raspberry Pi 1, but when I run the code: curl -sL https://deb.nodesource.com/setup_7.x | sudo -E bash -, I am presented with:

## Installing the NodeSource Node.js v7.x repo...

## You appear to be running on ARMv6 hardware. Unfortunately this is not currently 
supported by the NodeSource Linux distributions. Please use the 'linux-armv6l' binary 
tarballs available directly from nodejs.org for Node.js v4 and later.

How can I install Node.js v7 on a Raspberry Pi 1?

0

I think you can follow a similar procedure as this one. I.e.

  1. Uninstall original
  2. Re-install newer one but compiled for ArmV6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.