0

I am using Raspbian Jessie, kernel 4.4, and the pixel Desktop. when I try to set pcmanfm up as the file-system manager, the option in the "Customize" section of "Panel preferences" the selection stays blank.

How can I set pcmanfm to be my default package manager?

3
  • 1
    By default, the file manager is pcmanfm...did you change it and are trying to get it back? – NULL Jan 18 '17 at 14:28
  • I haven't used PIXEL but I doubt they wrote a new file manager as well, and since it is presumably mostly still LXDE, NULL's right, the fm would be pcmanfm. Are you sure it isn't? – goldilocks Jan 18 '17 at 14:49
  • 1
    Its on the system for sure. when I try to use the directory applet, it says no file manager is configured. when I try to configure it, I can't. – j0h Jan 18 '17 at 15:02
1

You can set the Default file manager in Default Applications for LXSession. This can be found under Preferences, but you usually have to add it to the menu.

To add it to the menu:

  1. Open Preferences > Main Menu Editor.
  2. Click on Preferences on the sidebar to the left and check the box next to Default Applications for LXSession.

To setup default File Manager

  1. Open Preferences > Default Applications for LXSession.
  2. Under File Manager, select PCManFm.

NOTE: You will only ever need to do steps 1 and 2 once.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.