2

It's driving me up the wall, but I can't find a solution to this. I've got a Raspberry Pi Zero, and I'd like to put Risc OS on it. Grabbing the Risc OS 99meg install file and using Win32DiskImager to SD card it onto the Zero did nothing. Black screen. Installing NOOBS did work however. NOOBS has a Shift key boot option that should allow selection of different OSes - but it doesn't show any alternative OSes (apart from Raspbian). I think this is because the PiZero has no wired connection, and the wifi dongle hasn't yet been booted up. So there's no way to choose an OS.

Very grateful if anybody has a solution - or perhaps the Raspberry Pi Zero simply can't run RiscOS

  • As an aside - I've tried creating a folder called RISC OS inside the os part of NOOBS, on the SD card. Inside it I put files found here link (not including archive and images), but it doesn't show up on the NOOBS shift screen – Robin Jan 19 '17 at 1:51
  • It may be that the zero can't handle it. Have you tried the RiscOs Pico version? – Chenmunka Jan 19 '17 at 13:42
1

NOOBS needs an internet connection for it to display all the other OSs that are available. For some reason, on the PI3, the latest NOOBS no longer has RISCOS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.