2

I have tried:

modprobe ipv6

Which returns

modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.4.21-v7+/modules.dep.bin'

It has worked until today after I rebooted my pi. I ran an update yesterday which might have caused it.

/lib/modules only contins the following folders:

  • 4.4.38+
  • 4.4.38-v7+
  • 4.4.43+
  • 4.4.43-v7+

Does anyone know how to fix it? I would very much like to be able to resume serving ipv6

Additional info:

  • rpi-update = Your firmware is already up to date
  • apt-get update/upgrade = No effect
  • It might be caused by running the pi off of an external disk. uname -a shows 4.4.21-v7+ Sep 15, but I just updated the firmware today

I got it to work. I not entirely sure how. I think it's because I had a line in fstab:

/dev/mmcblk0p1 /boot/firmware vfat defaults 0 2

But I'm not 100% sure so I don't know if I should post it as an answer.

1

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911

Assuming ipv6 broke after running rpi-update restore from your backup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.